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OVERVIEW 

This course is designed to familiarise schools with a number of commonly performed tasks and 

procedures. 

It is a collection of guides covering such topics as managing borrower records, modifying Class 

descriptions, understanding loan types, setting circulation dates, updating the Calender with closed 

days, importing SCIS records, adding new items to the Stockitem module, modifying records using 

the Cataloguing worksheet, creating kits using the Master/Subsidiary function. 
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CHECKLIST OF TASKS FOR THE BEGINNING OF THE YEAR  

TASK SCREEN  

Deletion of students/staff who have left – for example: Year 7s, Year 12s, Staff 

 Students can be Mass Deleted (Query those to be deleted, highlight the List and select 

Table > MassBorrowerDelete– those with loans, reservations or memos will remain) 

Borrower screen > Application  

Changes of Class Descriptions (if applicable) 

 Class descriptions may need to be altered to reflect new teachers’ names etc. 

Borrower screen > Application > BorrowerClasses  

Office download to load new students (or manually change students through global 

changes) 

 Separate notes are available if necessary 

Borrower screen > Application > BorrowerImport  

Add new staff (manually or through Maze) Borrower screen > Application  

Date Changes for Global date, end of term, end of semester, end of year etc. 

 Hint: Leave enough time to follow up overdues – for example: 6/12/2008 

Main > Supervisor > Installation > Circulation tab  

Add Final Dates to Borrower Types (as applicable) 

 For Term Loans or Year Groups who leave earlier – for example: Yr 11s, 12s 

Borrower screen > Application > BorTypes  

Add closed dates to calendar (Including Holidays) Main > Supervisor > Installation > Circulation tab as well 

as Calendar 

 

Ensure that Backup procedures are in place and that logs of Backups are checked regularly This is very important – contact our office if you are in 

doubt…. 
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BORROWER MAINTENANCE 

A new calendar year for schools means new term times, new students, students who need deleting 

(some which probably still have loans or memos!). 

 Deletions: Non-returning borrowers 

 Additions: New students either manually or through a download from Administration (SIS, 

Maze, etc.) 

 Changes: Dates, Class descriptions 

Deletions 

Deletion of the Students who have left 

It is best to delete students who have left BEFORE adding new students. For example: in a Primary 

School this will be the Year 6 students. In a Secondary School, it is the year 12 students (at least 

those who have graduated).  

The following instructions are for a Secondary School. 

1. Launch the Amlib client 

2. Go to Main > Borrowers > Borrower the Borrower Details screen will display: 

 

3. In the Type field type the code – for example: 12 

4. Click the F5 Query button – the Borrower List table will display containing a list of the 

matching borrowers 

5. Select the borrowers to be deleted by highlighting the rows 

To highlight: 

 All the borrowers: run the mouse down the left column 

 Selected borrowers: press the Ctrl key and click with the left mouse button 

 A range of borrowers: click the first borrower in the range, scroll to the the last borrower in 

the range, click the Shift key and click the last borrower (useful for highlighting all of a big 

list!) 
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6. From the menu, select Table > Mass Borrower Deletion – a prompt with display asking: You 

are about to delete the Selected Borrowers. Do you want confirmation of delete 

messages? 

 

HINT: You have already highlighted the borrowers for deletion. Confirming each and every borrower 

to be deleted will slow down the process. 

7. If you click the No button: 

a. All borrowers highlighted in the table will be deleted unless the borrower has loans, 

reservations or memos (no messages display) 

b. Once complete the following message will display: All XX Borrowers have been 

deleted. 
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c. If there were borrowers that could not be deleted, then the following message will 

display: Out of the XX Borrowers selected for deletion there were XX Borrowers 

that could not be deleted due to confirmation messages and/or Group Security 

issues. 

 

d. Click the OK button 

8. If you click the Yes button: 

a. Each borrower’s ID will display: 

 

b. Messages will also display if the borrower cannot be deleted (for example: the 

borrower has loans, reservations, memos or owes money): 

 

 Other Students who have left can be found and deleted by using F4 Delete in the Borrower 

Details screen 

Please Note: Students with Loans, Reservations, Memos for fines owing will not be deleted. If a 

student has left with items showing on loan, if the books are unlikely to be returned, it is suggested 

that these items be returned from the patron and either made lost or deleted so that the student (or 

teacher!) can be deleted from your database. 
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Additions 

New students need to be added. This can be done manually or automatically using a download from 

the Administration database. If you use separate barcodes in the library rather than the student ID, 

then these barcodes will need to be added to the records. This can be done by selecting the New 

Saved File created in the Import of patrons: 

1. Launch the Amlib client 

2. Go to Main > Borrowers > Borrower – the Borrower Details screen will display 

3. From the menu, select File > DisplayFile – the Borrower Saved Query Results screen will 

display 

 

4. Select the New Saved File and click the F9 Select button – the Borrower List screen will 

display: 

 

5. Double-click (or select the <Enter> key)on the first borrower on the list to display their 

record in the Borrower Details screen: 
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6. For each student: 

a. Wand in the new barcode 

b. Click the F3 Update button to save the changes – a prompt will display with the 

following message: The Borrower Barcode has been Changed. Continue with 

Update? 

 

c. Click the Yes button – a prompt with the following message will display: The 

Borrower Bar Code has been Updated. 

 

d. Click the OK button – a prompt with the following message will display: The 

Borrower has been Updated. 

 

e. Click the OK button 

7. Click the F9 button to move to the next student in the list and repeat 

8. Continue until the class or file has been finished 
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Class Descriptions 

Some of the Class descriptions may need to be change because of Staff, room changes, etc.  

1. Launch the Amlib client 

2. Go to Main > Borrowers > BorrowerClasses – the Borrower Classes screen will display 

3. From the menu, select File > DisplayFile – the Borrower Saved Query Results screen will 

display 

 

4. Make any alterations to the table 

5. Click the F3 Save button when complete 
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BORROWER IMPORT 

The Borrower Import function enables sites to import borrower data from an Administration system 

(for example: Cases, EDSAS, Maze, Synergetic, etc) into the Amlib system.  

This allows for: 

 New borrowers, including address information, to be included in Amlib without having to 

manually enter them 

 Updates of existing borrower records with new Type, Class codes, addresses etc. 

This function is predominantly used by school libraries at the start of each year/semester to update 

their student records (or add new ones). 

The program allows for the restoration of the old data if necessary. 

It has a facility to “map” administrative codes to those used on your Amlib database. They do not 

have to be the same codes, but need to be matched to the corresponding codes so they will import 

correctly for each borrower record. 

The data file to be imported can be copied from the administrative database onto a USB drive, CD or 

to a file accessible on the network. You will need to know the exact path so that you can access it 

during the Borrower download process (from your administrative database). Once the data file has 

been downloaded from the administrative database, it can be uploaded into Amlib.  

The file sent to you should be in one of the following file formats: 

 CSV (comma delimited) 

 TAB delimited 

 Pipe separated (|) 

You can have empty fields in your import, but they must be left empty and not have the data moved 
across. For example: if you didn’t have a Second Name or Preferred Name, you would leave two 
blank fields where they should be in your file: 

 

Example format (CSV): 

 ANDERL,ANDERTON,LAURENCE,WILLIAM,LAURIE,1,RED,B1SJ,1/01/83,M,BB,MR & MRS W B 

ANDERSON, 5/165 KING EDWARD STREET,BAYSWATER,WA,6053,9462 1111 

If the above example left out the RED Group code, the data would be: 

 ANDERL,ANDERTON,LAURENCE,WILLIAM,LAURIE,1, ,B1SJ,1/01/83,M,BB,MR & MRS W B 

ANDERSON,5/165 KING EDWARD STREET,BAYSWATER,WA,6053,9462 1111 

Pipe (|) separated: 

 ANDERL|ANDERTON|LAURENCE|WILLIAM|LAURIE|1| |B1SJ |1/01/83|M|BB|MR & MRS W B 

ANDERSON|5/165 KING EDWARD STREET|BAYSWATER|WA|605|9462 1111 
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Dates must be formatted in one of the following three ways: 

 11/12/09 

 11/12/2009 

 11 Dec 09 

If there are trailing spaces in the data, the program strips these out and causes no problems with the 

download. 

Format 1: MAZE, Synergetic, CASES, COSYCORNER 

This format contains only 17-18 fields, which should be downloaded into a data file from the 

administrative software (for example: MAZE, Synergetic, CASES, COSYCORNER, etc.) in the sequence 

as shown below.  

Mandatory Fields: The data must include Borrower Shortname (Unique ID/BarCode), Surname and 

Type. These cannot be left as null fields. Any unused fields should be left blank but included as null 

fields.  

FIELD CSV COLUMN EXAMPLE 

1. (Unique ID/BarCode) 
Borrower Short Name/MAZE Key 

A ANDERL 

2. Surname B ANDERSON 

3. Given  C LAURENCE 

4. Second Name (only imports initial) D WILLIAM 

5. Preferred (overrides Borrower Given) E LAURIE 

6. Type F 1 

7. Group G RED 

8. Class H B1SJ 

9. Date of Birth (or date of entry depending on 
what is used by the admin. database) 

I 1/01/83 

10. Sex J M 

11. Location K BB 

12. Contact name L MR & MRS W.B. ANDERSON 

13. Contact Address Line 1 M 5/165 King Edward St 

14. Contact Address Line 2 N Bayswater 

15. Contact Address Line 3 O WA 

16. Postcode P 6053 

17. Contact Phone Number Q 9462 1111 

18. Email (Optional) R john.smith@oclc.org 

mailto:judy@infovision.com.au
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Format 3: SIS (WA Education Dept) 

This format contains only 22 fields, which should be downloaded into a data file from the 

Administrative software (SIS) in the sequence as shown in below.  

Please Note: All files must be in a standard .CSV format. Any unused fields should be left blank but 

included as null fields. 

FIELD # FIELD NAME TYPE & SIZE EXAMPLE 

1 (Unique ID) 

ID/REF/BarCode 

Alpha Numeric 15 1234 

2 Type Alpha Numeric 1 1 student 

2 teaching staff 

3 Non Teacher 

3 Date of Birth Date 12 JAN 1993 

4 Sex Alpha Numeric 1 M / F 

5 Surname Alpha Numeric 40 Smith 

6 First name Alpha Numeric 40 Jonathon 

7 2nd name Alpha Numeric 20 Peter 

8 3rd name Alpha Numeric 40 Paul 

9 Preferred name Alpha Numeric 40 John 

10 Addr line 1 Alpha Numeric 40 151 Royal St 

11 Addr line 2 Alpha Numeric 40  

12 Addr line 3 Alpha Numeric 40  

13 Suburb Alpha Numeric 50 East Perth 

14 State Alpha Numeric 40 WA 

15 Postcode Alpha Numeric 10 6004 

16 Phone 1 Alpha Numeric 30 9264 1111 

17 Phone 2 Alpha Numeric 30 9264 1113 

18 E-mail Alpha Numeric 100 john.smith@oclc.org 

19 Parent Salute Alpha Numeric 60 Mr & Mrs Smith 

20 Class Alpha Numeric 15 Room 5 

21 Group (Type) Alpha Numeric 2 4 (K, P 12, up etc) 

22 Entry Date Date 22 SEP 1998 
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Format 3: All Fields/EDSAS (SA Education Dept) 

You must have at least 19 columns, although you can go up to 25.  

Mandatory Fields: Borrower Shortname(Unique ID/BarCode) and Borrower Type.  Additionally, you 
need to have data in the Location column even if this does not come from your Admin system.  If you 
do not store patron location against the student in your admin system, you can just put a 1 in every 
line of the file and match this 1 to your library location later. 

Please Note: If the data file only contains 19 fields the Guardian details are copied from fields 12 – 
16. Any unused fields should be left blank but included as null fields. 

FIELD CSV COLUMN EXAMPLE 

1. (Unique ID /BarCode) 
Borrower Short Name  

A ANDERL or B9988 

2. Surname B ANDERSON 

3. Given Name C LAURENCE 

4. Middle Name (only imports initial)  D WILLIAM 

5. Preferred Name (overrides Given) E LAURIE 

6. Type F 1 

7. Group G RED 

8. Class H 10A 

9. BirthDate I 01/01/91 

10.  Sex J M 

11.  Location K BB 

12.  Address 3 Line 1 (Guardian Name)  L MR & MRS ANDERSON 

13.  Address 1 Line 1  M 5/165 King Edward St 

14.  Address 1 Line 2  N Bayswater 

15.  Address 1 Line 3  O WA 

16.  P/Z Code P 6053 

17.  Address 1 Tel. Q 08 9462 1111 

18.  Email R laurie@oclc.org 

19.  (Other ID) Ref2  S 18846 

20.  Address 3 Line 2 T 8 Osborne Rd. 

21.  Address 3 Line 3 U Innaloo 

22.  Address 3 Line 3 (merges with 
above) 

V WA 

23.  Address 3 Postcode/Zip Code W 6017 

24.  Address 3 Tel. X 08 9754 0000 

25.  Mobile/Cell Y 0425 113 655 

mailto:judy@infovision.com.au
mailto:laurie@oclc.org
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How Records Are Matched 

The records will be matched in the following way: 

1. Unique ID/Other ID – If the Unique ID/Other ID (BarCode/Ref2) from the file is found in 
Borrower, then the information for that patron will be overwritten with the data there, 
regardless of whether or not the name is the same. So if a student changes their surname, 
the new surname would come across in the import as long as the Borrower ID/Barcode is 
identical. 

2. Surname/Given Name – If no matching Borrower ID/BarCode is found, the system will then 
do a search for any matching surnames and first names. If there is one match found, the 
system will overwrite that record with the data in your file. 

3. Date of Birth – If more than one match is found for the surname and first name, the system 
will then try to locate the correct one using the date-of-birth. If a matching date-of-birth for 
that surname and first name is found, that record is updated. If the birthdates for these 
Borrowers are null then the Borrowers are considered duplicates (and the system creates a 
new record with an auto-generated AMLIB BarCode). 

In the example below John Goldsmith changed his Surname to Smith. The BarCode in the Amlib 

borrower record was identical to the Unique Import Key (Unique ID), therefore the details were 

updated, showing the Borrower details with the new Surname. 

 

 The Borrower Import will remove single quotes from any incoming names – for example: 

O'Brien becomes OBrien.  

Suggested ‘Pre-import’ Tasks 

You may wish to move all year 12 students (or year 6 students – for primary schools) into another 

class such as Year 13 or Year 7 using Mass Borrower Change. From there you can upgrade all other 

years and import new students. Any returning year 12 (or 6) students would be updated and moved 

back to class year 12 (6). All Remainder students can be dealt with as necessary. 

Alternatively all students may be mass changed to a generic class via Mass Borrower Change, thus 

giving all students a single class. When doing then next import, all classes will be changed to the 

correct class.  Any left with the generic class can be dealt with as necessary. 

Before starting the import process, check the Type, Group, Class and Location tables in Amlib to 

ensure all required codes have been created. Check the Location table to ensure that the locations 

required have a Valid for Borrower setting of Y. 
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Importing Into Amlib 

1. Launch the Amlib client 

2. Go to Main > Borrowers > BorrowerImport – the Borrower Import screen will display: 

 

3. Click the F1 Open button – the Import File… screen will display: 

 

4. Browse to file to be uploaded, select (highlight) it and click on the Open button 

5. Your data will appear in the Borrower Import screen and a prompt will display with the 

following message: All the Type, Group, Class and Location Codes have been loaded from 

the Import File.  Use the ‘Setup’ menu to assign each Imported Code an equivalent Amlib 

Code before using the ‘Import’ option to update all the Borrowers. 
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The data read from the Borrower Import File can be sorted or have the actions calculated prior to 

importing the data into Amlib. 

6. To sort: From the menu, select Sort By > and select the sort field – the data can be sorted by 

Surname, Given name, Borrower Type, Group or Class. 

 

7. The calculate action option (Table > Calculate Action) will read the import data and state 

whether each student import will be UPDated, NEW or a DUPlicated student record 

 

8. If the F4 Import button is greyed out, it indicates the mapping between the imported codes 

needs to be setup (or adjusted) to match the codes used within Amlib. If it’s is bolded, the 

skip ahead to step 13 

9. From the menu, select Setup and then select one of the following Borrower fields: Types, 

Groups, Classes or Locations – in the example below, we have selected Types: 
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Please Note: If a selection is greyed out, this indicates there are no codes requiring mapping 

for that field.  Once a field has been successfully mapped a bolded tick will appear at the 

front of the selection. 

10. A Setup screen will display with two columns: The Imported Type and the Amlib Type. The 

Imported Type will be the data located in your Borrower Type column (Field 6/CSV column F) 

of your import file. The Amlib Type will be the codes located in the Main > Borrowers > 

BorrowerTypes screen. 

 

11. For each Imported Type, use the Amlib Type drop-down to select a Borrower Type you 

would like to match (map) it against 

   

Please Note: It is possible to map more than one Imported Type to the same Amlib Type. 

12. You will need to do this for all the bolded selections in the Setup menu – when you have 

finished all the fields, they will all have a bolded tick next to them and the F4 Import button 

will then be active (bolded): 

 

13. Click the F4 Import button – the Borrower Import Files screen will display – this screen allows 

you to create files to save New, Updated and Duplicate borrowers to.  It also allows you to 

Overwrite Given name(s) and initial(s) and to Use (their) Date of Birth for unique checking. 
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14. Type in the filenames, and tick the settings you would like to use, then click the OK button – 

a prompt will display asking if you wish to save any changed borrowers to a file for recovery 

purposes: It is recommended that all changed Borrowers be written to a text file for 

recovery purposes. Do you want to save changed Borrowers to a file? 

 

WARNING! This is your insurance for your borrower data and is thoroughly recommended!! 

15. If you click the Yes button, a dialog box will display so that you can choose the file name for 

your original data and where to save it 

 

Please Note: In subsequent downloads, the restore.txt or restore.csv file will already exist 

and a message will display asking if you wish to overwrite this file. You would normally 

respond Yes to overwrite the file. 
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16. Once complete, a prompt will display notifying you that: The Borrower Import is complete. 

 

Please Note: The import process can take several minutes (for example: 1-3 seconds per 

borrower). The status of the import displays at the bottom of the screen. 

17. If borrowers with duplicate Borrower IDs are imported, then you will receive notification of 

this as part of the completion notice: The Borrower Import is complete. Some Duplicate 

Borrower ID’s were detected – these Borrowers have been saved to the ‘Duplicate ID’ 

saved file. 
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File Checking 

1. An Amlib Unique ID (BarCode) was created for the borrower who had the same ID as 

someone else (AMLIB0000…): 

 

2. If you go into the main Borrower screen (Main > Borrowers > Borrower) and go to File > 

DisplayFile you will see your three files for new, updated and duplicate borrowers, and a file 

for any duplicate IDs if your import had any 
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Common Errors 

 The chosen file does not contain Borrower Import records. 

 

This could be caused by either having the information in the correct columns or having headings 

across the top of your document. Remove any headings and double check your file against the 

Import formats in this document. 

 The chosen file does not contain valid records. 

 

This could be caused by having headings across the top of your import file or it being saved in an 

incorrect format (for example: .xlsx and not .csv). Please remove any headings, ensuring that it only 

contains Borrower information and make sure it is in one of the three formats mentioned at the 

beginning of this document. 

Please Note: It is always a good idea to run a Borrower Import on your test databases first, to ensure 

no errors happen. If you do not have a test databases, please contact Support via one of the above 

methods to find out how to set one up. 
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Borrower Import Matching 

The following explains the exact method in which Amlib matches on borrower imported records: 

1. Uses the Unique ID to match on Borrower BarCode 

2. If no matches then uses the Unique ID to match on Borrower Ref2 

3. If a Preferred Name has been Supplied: 

 Matches on Surname and Preferred EXACTLY 

4. If 2, matches on Surname and Preferred EXACTLY 

5. If Date-of-Birth Supplied: 

 Searches on Surname, Preferred and Date-of-Birth 

6. If no matches and an Initial has been supplied: 

 Matches on Surname, Preferred and Initial 

7. If no matches and an Initial has NOT been supplied: 

 Matches on Surname, Preferred and NULL Initial 

8. If no Date-of-Birth Supplied: 

9. If no matches and an Initial has been supplied 

 Matches on Surname, Preferred and Initial 

10. If no matches and an Initial has NOT been supplied 

 Matches on Surname, Preferred and NULL Initial 

11. If no matches on Surname and Preferred EXACTLY 

 Searches on Surname EXACTLY and LIKE Preferred (for example: Preferred%) 

12. If no matches then matches on Surname and Given EXACTLY 

13. If 2, matches on Surname and Given EXACTLY 

14. If Date-of-Birth Supplied: 

 Searches on Surname, Given and Date-of-Birth 

15. If no matches and an Initial has been supplied: 

 Matches on Surname, Given and Initial 

16. If no matches and an Initial has NOT been supplied 

 Matches on Surname, Given and NULL Initial 

17. If no Date-of Birth Supplied: 

18. If no matches and an Initial has been supplied: 

 Matches on Surname, Given and Initial 

19. If no matches and an Initial has NOT been supplied: 

 Matches on Surname, Given and NULL Initial 

20. If no matches on Surname and Given EXACTLY 

 Searches on Surname EXACTLY and LIKE Given (for example: Given Name) 
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 BORROWER PICTURE IMPORT 

The Borrower Picture Import utility allows the library to bulk import patron photographs from a file, 

usually provided by the student photographer. 

Some important factors to ensure a successful import are: 

1. Files may be either .jpg or .gif format only 

2. All individual student photo files should be located within a single folder (if the photos are 

separated out into year level folders, then the import will need to be run for each year level) 

 

3. Image files must be named using the following conventions only (this is required for 

matching purposes): 

 Surname followed Given Name –for example: smithsarah.jpg or smithsarah.gif (if a 

middle initial is required to correctly identify multiple patrons with the same name it 

must be in the format SurnameFirstnameInitial – for example: smithsarahj.jpg or 

smithsarahj.gif) 

 Patron barcode– for example: B37865.jpg or B9988.gif and these must match the 

exact BarCode found in the Amlib Borrower screen 

 Exact data found in either the Ref1 or Ref2 field of the Amlib Borrower screen – for 

example: R45787 or S37586 
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Set Up the Shared Image Directory 

Ensure that there is a shared Image directory created on the Amlib server for the images to be saved 

into as part of the import process.  For example: \\libraryserver\Images. The path will depend on 

the shared directory created but generally should be in the format of \\ServerName\Images.   

Ensure that the Images directory exists in the relevant path and that this directory is able to be 

shared so that all computers on the network are able to see the pictures. 

Setting up the Supervisor Parameters 

1. Go to Main > Supervisor > Installation – the Installation screen will display 

2.  Click on the Other tab 

3. Scroll down to the setting Location’s Picture Directory and enter the directory file path: 

\\libraryserver\Images (being the file path determined above) – for example: 

\amlib\mmedia\images 

 

file://libraryserver/Images
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4. Click the F3 Save button 

The parameter which sets the file types (gifs or jpgs) of the pictures is required next: 

5. Click on the Borrower tab 

6.  Scroll down to the setting Borrower images to be kept in files enter (eg .jpg or .gif) and enter 

either .jpg or .gif depending on the type of files you are going to load 

 

Both of these settings must then be copied to all locations: 

7. From the menu, select Installation >  Advanced Copy – the Advanced Parameter Copy screen 

will display: 
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8. In the first box scroll to the setting Borrower images to be kept in files enter (eg .jpg or .gif) 

and tick this box and then scroll further down to Location’s Picture Directory and tick the box 

beside it (this selects both parameters for copying to the other locations) 

9. In the table below are the other locations: choose the Select All button next to this table to 

automatically tick all of the other locations 

10. At the top of the screen click the F6 Copy button – a prompt with the following message will 

display: The parameters have been copied. 

 

11. Click the OK button 

12. Click the Done button in the bottom right-hand corner of the screen 

13. Exit and restart the Amlib client for these settings to take effect 

Running the Borrower Picture Import 

1. Navigate to Main > Borrowers > BorrowerPictureImport – the Borrower Picture Import 

screen will display 

2.  This screen is broken up into 6 steps: 

a. (1) Source Directory of Pictures: select the Browse button and use the drop-down 

arrow to browse to where the image files are currently stored, whether this is on a 

drive, USB or CD-ROM – browse to the file folder, highlight any one file from the 

folder and click the Open button 
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b. (2) Output Directories for Matched Pictures (se in Supervisor): have previously been 

set in the Supervisor module (see above), so no changes need to be made here: 

 

c. (3) Output directory for Non Matched Pictures: allows you to create a folder to save 

any photos that are not matched to patrons during the import process –Browse to a 

location where you would like to save these files, Make a New Folder if necessary 

and click the OK button when you have chosen a folder: 
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d. (4) Match picture filename on: from the drop-down choose what you intend to 

match against – this is wholly dependent on how your images files are named – for 

example: Barcode, Name, or data in Ref1 or Ref2: 

 

e. (5) Saved file for matched borrowers: create a file into which saved all patrons that 

are matched with a photo can be saved – choose the Select button to bring up the 

Borrower Saved Query Results screen, highlight a list (or click F1 New, enter Details 

and click F3 Save) and then click the F9 Select button to insert that file into the 

Borrower Picture Import screen 

 

f. (6) When all of the necessary data has been entered, the F3 Start button will become 

bold 

3. Click the F3 Start button to begin the import 

4. When the import is complete – the a prompt will display indicating the number of Pictures 

matched – for example: Pictures matched = 11 of 11 
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5. Click the OK button 

6. Close the Borrower Picture Import screen and search for a patron in the Borrower or Issues 

module to see the matched displayed image: 
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MASS BORROWER CHANGE 

Most school libraries use their Administration data to update patrons for the new Student year. If 

this is not available, it is possible to globally change students to their new classes or groups, as 

shown below. 

This process can be used to change Borrower Group, Type, Class, etc. The example used here is 

Borrower Group.  

1. Launch the Amlib client 

2. Go to Main > Borrowers > BorrowerWhere – the Borrower Where screen will display 

3. Create a Where clause – for example: Group = CHI (this will search for all Borrowers who are 

in that particular group) 

a. Highlight the field to search on: Group 

b. Choose Operator: = 

c. Enter the Where condition, or the exact data you want to find – for example: CHI 

d. Click the Paste button to insert the clause into the table 

 

4. Click on the F7 QtoFile button – the Borrower Saved Query Results screen will now display: 
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5. Click on the F1 New button to create a new Saved File 

6. Type in a name for the file in the Details column – for example: Groups to Change 

7. Click on F3 Save button 

8. Highlight the new Saved File and click on the F9 Select button to save results to this file 

  

9. A prompt will display noting the number of borrowers contained in the file 

 

10. Click the OK button 

11. Go to Main > Borrowers > Borrower – the Borrower screen will display 

12. Select File > DisplayFile – the Borrower Saved Query Results file screen will display 
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13. Highlight the required Saved File and click on the F9 Select button to display the file 

14. From the Borrowers List screen, select Table > Mass Borrower Change 

 

6. The Mass Change of Borrowers within a File screen will display: 

 

7. Enter the following settings: 
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a) Select the field you wish to change for all stockitems in the file example -  Group 

b) Type in the new value example, which is what you are changing all stockitems to be – for 
example: DUT 

c) Click on the Paste button to insert the new criteria into the bottom table 

d) Click on the F3 Update button to start the mass change 

15. This will change all the Borrower Groups in this file so that they are now Dutch 
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HOW TO CREATE A BORROWER BARCODE LIST 

Amlib has the facility to print lists of barcodes: 

 Install the barcode font – see attached ZIP file 

 Use the &BARCODG.QRP (list of barcodes: Name and Group) or &BARCODE.QRP (list of 

barcodes: Name only) 

Install Barcode Fonts 

1. Unzip the attached Barcode Fonts.zip file 

2. Create a folder named Barcode Fonts  

3. Copy the Barcode Fonts folder into your Amlib folder on the C: drive or network server 

4. On your PC: 

a. Go to Start > Control Panel > Fonts 

b. From the File menu, select Install New Font... 

c. Find the Amlib folder and double-click the Barcode Fonts folder 

 

d. Choose Select All to select both font files 

e. Click the OK button 

 The fonts will then be loaded. 

Save the Template 

 Save both the &BARCODE.QRPand &BARCODG.QRP templates into the Amlib/Reports 

folder on the Amlib server.  This will make the template available for use for all users. 

Alternatively, you may save it into a local folder on your PC – but please be aware, that the 

template (once loaded) will only be available for use on that PC.  
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Load the Template 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Report Files screen will display 

3. Select Borrower from the Report Entity drop-down menu 

4. Click the F1 New button – the Borrower - New Report File screen will display 

5. Type in a Description – for example: Barcodes by Group 

6. Click on the Browse button – the Choose Report screen will display: 

 

7. Change the Files of Type: dropdown to System Report Templates (&*.qrp) 

8. Navigate to the Amlib/Reports folder on your Amlib server and locate the &BARCODG.QRP 

template to be loaded (if the template has been loaded onto your PC – then navigate to the 

local folder) 

9. Click the Open button 

10. Choose Type = Borrower (Default) 

11. You can leave Default Stats Code and Default Detail Stats Code blank 

12. Update Entity (Y/N) = N 

13. Click the F3 Update button 
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14. Repeat steps 5 - 14 to add in &BARCODE.QRP – Barcodes by Name 

15. Close out of the Report Files screen 

Create the Report 

1. Go to Main > Reports > RepBorrower – the Borrower Reports screen will display 

2. Click the F1 New button 

3. Select the Barcode by Name (&BARCODE.QRP) or Barcode by Group (&BARCODG.QRP) – 

you will need to load separately 

 

4. Type in a Report Description – for example: Barcodes for Students 

5. Click the F3 Save button 
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6. Click the F7 Where button – the Borrower Reports – Where screen will display 

a. Add in search criteria for BorGroup, BorClass and/or BorType (or whatever you wish 

to choose) 

b. Click the F3 Save button when complete 

7. Click the F9 Order button – the Borrower Reports – Order By screen will display 

a. Use the arrow keys to add your sort by fields (for example: BorGroup and Surname)  

b. Click the F3 Save button when complete 

 

8. Click the F8 View button – a prompt with the following message will display: This type of 

report may use a Saved File as a Source. Do you want to select the file now? 
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9. If you had previously entered no F7 Where parameters, you may wish to click the Yes button 

and select a Saved File from the list, otherwise click the No button 

10. The Report – View screen will display: 

 

11. You can print from this screen by choosing the printer icon at the top of the screen 
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START OF YEAR DATES 

There are two sets of dates that require adjusting at the start of the year/semester/term: the 

Supervisor Installation settings and the Borrower Type settings. 

Supervisor Settings 

Default 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

3. Select the Circulation tab 

 

4. Adjust the following settings: 

a. All items must be returned by the following date: 

b. All Semester loans are due back on the following date: 

c. All Term loans are due back on the following date: 

d. All Year loans are due back on the following date: 

5. Dates must be entered in DD/MM/YYYY format – for example: 15/12/2011 

6. Click the F3 Save button 

7. Exit and restart the Amlib client for the new settings to take effect 
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Location  

It is also possible to adjust these settings by individual Location, allowing for a different set of dates 

to be entered.  It is very important to check your other locations to make sure that old dates are not 

saved in there. 

1. From the Supervisor module Installation screen: from the menu, select Installation > Choose 

Location – the Installation location screen will display 

2. Select a location (for example: Chelsea Library) and click the OK button 

3. The Installation screen for that location will then display – for example: Chelsea Library 

4. Select the Circulation tab 

 

5. If you would like to use the DEFAULT settings, then you can leave the date settings in this 

table blank, otherwise adjust the following settings (these settings will apply only to that 

location): 

a. All items must be returned by the following date: 

b. All Semester loans are due back on the following date: 

c. All Term loans are due back on the following date: 

d. All Year loans are due back on the following date: 

6. Dates must be entered in DD/MM/YYYY format – for example: 15/12/2011 

7. Click the F3 Save button when complete 

8. Repeat for all other circulating locations (including WEB – the location used by the NetOpacs) 

9. Exit and restart the Amlib client for the new settings to take effect
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Borrower Settings 

1. Launch the Amlib client 

2. Go to Main > Borrowers > BrorrowerTypes – the Borrower Types screen will display: 

 

For each borrower type it is possible to enter a Return By Date that overrides the Supervisor Date 

settings and allows for return dates to be set earlier (if the Return By Date is set after the Supervisor 

Date settings, then these Supervisor Dates will be the cut off point for returns). 

3. Enter a date in DD/MM/YYYY format in the Return By Date field of a selected borrower Type 

– for example: 15/11/2011 

4. Repeat for any borrower Type where the Return By Date is required to be different  

5. Click the F3 Save button when complete 

6. Exit the Borrower module (Ctrl-L) for these settings to take effect 
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DAYS CLOSED/HOLIDAYS (INSTALLATION & CALENDAR) 

Days Closed 

If the Libraries at all campuses are closed on common days (for example: weekends) it is possible to 

set these days closed in the Supervisor module: 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

3. Select the Circulation tab 

 

4. Adjust the following settings: 

 Days of the week when ALL Locations are closed (Sun=0, ...., Sat=6) – type in 06 if 

closed Saturday and Sunday 

5. Click the F3 Save button when complete 

6. Exit and restart the Amlib client for the new settings to take effect 
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Holidays 

It is possible to mark days (holidays) to be ‘closed’ in the calendar (for example: Easter).  

When an item is issued, the program will ensure that it the item is not due for return on closed 

dates. Reservations will not be due for collection on closed dates. Dates may be entered as far in 

advance as desired. 

To mark a date as a closed: 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Calendar – the Calendar screen will display 

3. Use the F7, F8, F9 and F10 buttons to navigate to a month where you want to set a closed 

date: 

 

4. Select a date with your mouse – for example: 1 November 2011 

5. Click the F2 Set button – the Holiday prompt will display: 

 

 Type in a suitable description in the dialogue box – for example Melbourne Cup or 

Term Break 

 Click the OK button 
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6. The date will be marked in red (indicating it is closed) – the Date and Description will appear 

in the table to the right of the calendar: 

 

7. Once the dates have been set, click the F3 Update button 

8. Exit and restart the Amlib client for the new settings to take effect 

Please Note: Where a Return By date falls on a closed date, the system allocates the next non-closed 

date past that date. 

Arrow Keys [F7], [F8], [F9], [F10] 

To scroll through the calendar you may use the F7 through F10 keys: 

F7 << Scrolls to the beginning of the year. Clicking again, 

scrolls back to one year past 

F8 < Scrolls to the previous month for the year as 

displayed 

F9 > Scrolls to the next month for the year as displayed 

F10 >> Scrolls to the end of the year. Clicking again scrolls 

one year in advance 

Remove a Closed Date 

1. To remove a closed date, highlight the date 

2. Click the F4 Delete button – this will mark [x]the Closed date for deletion 

3. Click the F3 Update button when complete 

4. Exit and restart the Amlib client for the new settings to take effect 
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Copy a Closed Date to Other Locations 

Closed dates in Calendar can be copied to other Locations. 

1. From the menu, select Calendar > Copy To All – a prompt will display asking: This will make 

every location have exactly the same holiday settings as ‘XXX’. Continue? 

 

2. Click the Yes button – this will copy the closed settings to ALL locations 

3. Once complete, a prompt will display with the following message: Calendar successfully 

reproduced. 

 

4. Click the OK button 

5. Exit and restart the Amlib client for the new settings to take effect 

Different Closed Dates for Each Location 

If different closed dates are required for different Locations. 

1. From the menu, select Calendar > Choose Location – a Location prompt will display 

2. Select the Location and click the OK button 

3. The set the closed dates for this Location 

4. Click the F3 Update button when complete 

5. Exit and restart the Amlib client for the new settings to take effect 
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SCIS MARC IMPORT 

Accessing the Data for the Download 

1. Launch the Amlib client 

2. Go to Main > Authorities > MarcTakeUp (alternatively use Ctrl + M) – the Marc Import 

screen will display: 

 

3. Click the F1 Open button to display the Open dialogue box 

4. Locate the file to be processed by using the Look in: drop-down box – for example: if the file 

is on the C: drive, the Look in: box may say Local Disk (C:) 

5. Once the file name has been located, use your mouse to select it and click on the Open 

button 

There are two processing options: Bibliographic Data or Authority Data – this guide covers the 

import of Bibliographic Data. 

Bibliographic Data 

This option is to load records which are Bibliographic Data in machine readable format which can be 

imported into Catalogue, Authority and Stockitem (where appropriate) applications of Amlib. 

1. The Marc Import – Open screen will display: 

 



School Tasks in Amlib 

 

 

Last Updated: 9 August 2011 
Version: 5.3 
Date of Version: 9 August 2011 
 Page 51 

Please Note: If the Import file (Bibliographic or Authority) contains more than 9999 records, it is 

recommended that Open and Update is selected (ticked) so that all records can be loaded into the 

database. This eliminates the need to load in sections. The maximum records that can be viewed in 

the Holding file is 9999 records.  

HEADING FIELD EXPLANATION/OPTIONS EXAMPLE 

Marc Options Bibliographic 

Data 

Bibliographic data to be created 

for the Catalogue. 

Data from external 

source (for example: 

SCIS, SLOWA, Kinetica 

etc. with USMARC Tags) 

Authority Data Authority data for creation or 

updating of Authority Headings 

and/or cross references. 

See and See Also Update 

from SCIS or other source 

Update the database 

without viewing the 

Marc records 

Open and 

Update 

If checked (ticked), the imported 

items will not display in the 

Holding file.  

The Catalogue will be 

Updated immediately 

If unchecked (unticked), the 

imported items will display in 

the Holding file.  

Review records 

The Catalogue will not be 

updated until the F3 

Update button is 

selected 

Load Range All All records from the file are 

downloaded into a holding file. 

All 

Range Selected records from the file 

are downloaded into a holding 

file. If Range is selected, the next 

2 fields have to be updated. 

For example, 1 to 50 

2. Complete the options using the above table: 

a. Marc Options = Bibliographic Data 

b. Open and Update = ticked, unless you want to review each individual MARC record 

c. Load Range = All (unless the file sizes are quite large) 

3. Click on the OK button 
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Bibliographic Options 

1. The Bibliographic Options screen will display: 

 

HEADING FIELD EXPLANATION/OPTIONS EXAMPLE 

Marc Details We think the file 

contains 

The data type is displayed  

Standard format 

SCIS 

ABN  

 Total Bibliographic 

records 

The number of Bibliographic 

records will display 

32 

Total Authority 

records (this will only 

display if the import 

is for Authority 

headings) 

The number of Authority headings 

with See/See Also references will 

display 

0 
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2. Select the appropriate Each bibliographic record contains setting: 

Each 

Bibliographic 

record contains: 

Catalogue data only The system will determine the 

contents of the import file. If only 

Catalogue data exists in the file, 

this will be the Default option.  

SCIS Data 

 

Full Catalogue & 

Stockitem data 

The system will determine the 

contents of the import file. If both 

Catalogue and Stockitem data 

exists in the file, this will be the 

Default option.  

Please Note: This item can be 

selected to create “Dummy” 

Stockitems even though only 

Catalogue Data exists in the Import 

file. 

SL OF WA Data 

Brief Catalogue and 

Order data 

The system will determine the 

contents of the import file. If only 

brief Catalogue data and Order 

data exists in the file, this will be 

the default option. 

AOL Data 

When displaying 

the records 

show: 

All tags in the file All tags from the Import file will 

display in the Holding file for 

viewing. However, tags not defined 

in Amlib will not load into the 

Amlib Catalogue unless the Marc 

tag is defined. 

If Tag 650v is not used 

in Amlib it WILL still 

display in the Holding 

file. 

 

Only tags defined in 

Amlib 

Only tags used in Amlib will display 

in the Holding file.  

If Tag 650v is not used 

in Amlib it will NOT 

display in the Holding 

file. 
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3. If the Marc Details are set to import Full Catalogue & Stockitem data, the Item Default and 

Item Prices sections will also display: 

HEADING FIELD EXPLANATION/OPTIONS EXAMPLE 

Item Defaults 

Please specify 

default values 

for each item in 

the fields below 

Form The default values set in the Main 

> Supervisor > Installation > 

Stockitem tab will display if 

defined.  

If these fields are not yet defined, 

codes which will apply to the items 

can be entered. Rules for 

automatic entries of Form and 

Stats codes depending on the Tags 

that are imported, and be set in 

Cat Defs in the Stockitem Form and 

Stats codes. 

If during the Import, 

Cat definitions cannot 

be created, each 

Stockitem will have a 

default Form of BK 

(for example) 

 

Location CHELSEA 

Lib Group LIBRARY 

Stats Code ANF 

Floor Loc (optional) DISPLAY 

Process (optional) IN PROCESS 

Item Prices Minimum price of an 

item 

If the item price in the Import file is 

less than the price set here, enter 

the Minimum price 

The Import price is 

$8.00 but the 

Minimum price set 

here is $10.00, the 

price in the Stockitem 

will be $10.00 

 

Appreciate items by 

% 

Items can be appreciated by a 

percentage – for example: GST of 

10% 

10% 

Depreciate old 

stockitems 

Items to be depreciated will be 

dependent on the table set in 

Stockitem > Application > Stats 

Group 

 

Use average prices if 

no price 

Items will be given an average 

price, set in Stockitem > 

Application > Stats Group. If no 

price is entered in the Import File 

 

4. Click the OK button once you have completed modifying your settings 

Please Note: Form and Stats Code defaults from the Main > Supervisor > Installation > Stockitem 

tab display automatically in the fields. If there are no defaults entered, the field will be blank. 

Location displays as the Login Location. Entry of these fields is optional.  As the import of data is 

processed, the Stockitems will be given the default values if there are no catalogue definitions for the 

Form or Stats codes of the items. Form and Stats Code Cat definitions are found in Main > 

StockItems > StockitemForms or StockitemStatsCodes table for the particular code. 
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Reviewing Records to be Imported (Optional) 

It is possible for the importer to review (and edit) the MARC data being imported. 

1. If the importer has decided to review the records being imported (see Bibliographic Data 

step above), the Marc Import screen will display: 

 

2. If you do wish to edit the data (prior to import), use the editing buttons on the right to 

change or delete the individual tags 

Please Note: Editing of the data prior to import is not essential. Changes can be made after 

the data has been imported into the Catalogue. Remember that not all the tags will 

necessarily be Imported, so if editing is considered necessary, change only the tags you know 

will be imported! 

3. Use the F7, F8, F9 and F10 buttons to move between records 

4. Once the data has been reviewed, click the F3 Update button 

Find 

It is possible to use the find function to locate any matching text, tag number or specific Subfield in 

the Holding File data being displayed. For example: use this facility to check all Author entries or 

Subject headings. 

1. From the main menu, select Window > Find – the MarcImport - Find screen will display: 
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2. Type in the Tag, Subfield or String to find and click the Find Next button 

3. It will then find any matching data in the record currently being displayed: 

 

Catalogue Update Options 

1. The Update Options screen will then display, allowing you to select the Cat(alogue) and 

(Stock)Item Options: 

 Cat Options: When an incoming Catalogue is match with an existing Catalogue 

 Item Options: When an existing Catalogue is replaced all existing items 

 



School Tasks in Amlib 

 

 

Last Updated: 9 August 2011 
Version: 5.3 
Date of Version: 9 August 2011 
 Page 57 

PARAMETER FIELD EXPLANATION 

Cat Options 

When an 

incoming 

Catalogue is 

matched with 

an existing 

Catalogue: 

Display an IGNORE/REPLACE 

message 

A message will display at each match occurs. At each 

match, the operator will get a choice to create a new 

catalog, replace the existing or to keep the existing details.  

Keep the existing Record ie NO 

UPDATE 

No Update occurs for the Catalogue 

Add Authorities but Replace Non-

Authorities 

Does not replace existing Authorities but adds new 

Authorities to the record. However, it replaces any Non 

Authority data from the Import 

Replace the existing Catalogue 

ENTIRELY 

All tags from the Import are used, overwriting any existing 

data 

FIELD OPTION EXPLANATION 

Replace all 

tags EXCEPT: 

 

Don’t delete the 

following tags 

from the 

existing 

catalogue eg. 

650,700 

This will vary according to the setting in Main > Supervisor 

> Installation > Catalogue tab:  

 MARCImport Replace: don’t delete these tags 

from the existing cat 

 MARCImport Replace: don’t import  these tags 

from the existing cat 

Adds non-identical tags when importing all but specified 

Tags. Existing data in the specified Tags remains 

unchanged 

 

Don’t import 

the following 

tags from the 

incoming 

catalogue eg. 

650,700 

Adds non-identical tags when importing. Does NOT import 

the new data in the specified Tags. Existing data in the 

specified Tags remains unchanged 
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PARAMETER FIELD EXPLANATION 

Item Options  

When an 

existing 

Catalogue is 

replaced, all 

existing 

Stockitems: 

Keep their current display No existing Stockitems are refreshed – they remain the 

same 

Are refreshed from the Catalogue All existing Stockitems are replaced by the new Catalogue 

details 

Are refreshed except lines: 

eg. 1,5,6 

Enter the line numbers to be retained – for example: 6 

(Line 6, which is usually Call Number). Line numbers 

correspond to the 6 lines of Stockitem display (for 

example: Line 1 is usually Title, Line 2 Author etc.) 

FIELD OPTION EXPLANATION 

Please choose 

the location to 

use when 

matching an 

order 

Exact Only order items where location is the same as the 

current Amlib location will be candidates for replacement 

Any Stockitems on the file may replace any order item on the 

database 

Only create 

stockitems 

Checked The import of data will result in no Catalogue records 

being created. Only Stockitems will be created. 

Unchecked 

(Default) 

Create Catalogue records as well as Stockitems 

2. Enter the options you would like, then click the OK button – the Saved Files screen will 

display: 

 

3. Type the names of the files into which all the newly created Catalogues, Authorities and/or 

Stockitems will be saved (if you do not want to check new items – for example: Authorities, 

do not enter a filename) 

4. Click the OK button 

HINT: These files assist in finding the newly created Catalogues, Authorities and/or Stockitems after 

the import. The Filenames are created so that you can identify the file later. A suggested Filename 

could be the type of data – for example: SCIS or EXCHANGE, the date and the initials of the staff 

member processing the data. 
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5. If confirmation of duplicate items has been requested in the parameters, a Catalogue Match 

screen will display every time a duplicate item is found: 

 

6. Are the above two records the same? Click the Yes, No or Replace button 

OPTION EXPLANATION 

Yes The catalogue entry that exists on the database will remain as displayed in the top box. 

A new Stockitem would need to be added if appropriate. The imported record will not 

be included in the New File created for Catalogue or Authorities 

No A new catalogue will be created with the data from the Imported data being used for 

the new catalogue record. The imported record will be included in the New File created 

for Catalogues or Authorities 

Replace The existing catalogue entry will remain but the data will be replaced with the data 

from the imported recorded. The imported record will not be included in the New File 

created for Catalogue but there may be some additions to the Authorities file 

7. An Update prompt will display, indicating the progress of the import: 
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8. When the update is finished an Update prompt will display, showing the number of records 

Updated: 

 

9. Click the OK button 

10. You will be able to view the log by selecting the F6 Log button 

F6 Marc Log 

This log lists any errors that were experienced in the process of importing the file and also what 

action was taken with certain items. Most of the errors that display in the log are caused by the tag 

numbers not being defined on the Amlib database. This may be because we did not wish to use them 

in the Catalogue data but were present in the data file. 
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MODIFY A CATALOGUE RECORD USING THE WORKSHEET 

It is now possible to edit an existing catalogue record using the Catalogue Work Sheet. 

1. Launch the Amlib client  

2. Go to Main > Catalogue > Catalogue (or the  icon) – the Catalog screen will display 

3. Locate the item to be modified using F5 Query: 

 

4. From the menu, select Catalogue > Catalog Modify using Worksheet – the Work Sheet 

screen will display: 

 

5. The catalogue record can then be edited/modified in the same manner as a new Catalogue 

record 

  

Field Heading Subfield 
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6. To enter additional tags, click the F2 Insert button – the Select For Creation table will display: 

 

7. Find the required tag and double-click (or select and press <enter>) it to select it – a new 

entry with the selected Tag No will appear in the Work Sheet 

8. Add the required data 

9. Where the data is Authority based (for example: Author, Subject Heading, Series, etc.) a 

listing of Authorities can be viewed and selected – for example: to search for a particular 

Author, type the first few letters of the surname, highlight the row and double-click the row 

or press the F1 Check button 

10. Please Note: Existing Authorities cannot be altered in the Work Sheet – if a new Authority is 

to be created (for example: one with a different subdivision), then the F2 Insert button 

should be used to enter it on a new line to that of the existing heading (the existing heading 

can be retained or removed using the F4 Delete button) 

11. The Existing Authority Options screen will open displaying all matching Authorities and the 

number of Catalogue records which use each Authority: 
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12. To select an Authority in the table, simply double-click on it: the contents of the tag being 

checked will then change to match the selected Authority (the text will also change colour 

from black to green) 

 

↓ 

 

13. Once selected (or if there is no matching Authority), click on the red [X] to close the selection 

table (if there were no Authorities found the contents of the tag being checked will turn red, 

if there were Authorities found but none were selected the contents will turn pink) 

14. When the record is complete, click the F3 Save button 

15. If new Authorities are to be created, a prompt will display with the following message: Some 

new Authorities will be created. Continue with Save? (the new Authorities will be 

highlighted in red, so you can check them) 

 

16. Click the Yes button 

Editing of the record is now complete. 
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PROCESSING E-BOOKS & AUDIOBOOKS (WEBLINKS) 

It is possible to load e-book and audiobooks holdings into Amlib. 

 An e-book is a digital representation of a printed (hard copy) book. E-books are read via text -  

there is no sound capability and can be read (or viewed) with different software on a 

desktop, pocket PC, E-book reader, iPad, Kindle, smart Phone or other device that supports 

the file type that the book is in (for example: Adobe Acrobat Reader) 

 An audiobook is a sound recording of a book. It may be in cassette tape, CD, MP3 or WMA 

(Windows Media Audio) format. One listens to audiobooks via an iPod, MP3 player or on a 

PC. 

 An e-audiobook is a downloadable audiobook (these are available from OverDrive) 

E-books can be supplied via a vendor – for example: OverDrive, Bolinda, etc. See separate notes on 

setting this up. 

NetOpacs 

 Amlib can connect to e-book vendors using a SIP2 connector and therefore validate 

membership to the library with use of barcodes to make e-books and audiobooks available 

via the NetOpac Interface 

 Alterations to your Amlib NetOpacs – contact Amlib Support for a quote 

Authority 

Ensure the 856 – URL Authority tag has been defined, and that there is u and z subfields: 

1. Launch the Amlib client 

2. Go to Main > Authorities > MarcTags – the Marc Tags Within the System screen will display: 

 

3. Check to see if the 856 | Electronic location and access tag is in the list of tags (it may be 

also be called 979 | URL Link) 
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4. If it is NOT present, then you can add one as follows: 

a. Click the F1 New button 

b. Fill in the fields as shown in the table below: 

HEADING DETAILS 

Tag No  856 

Tag Description Electronic location and 

access 

Default Ind 1 <leave blank> 

Default Ind 2 <leave blank> 

Can the Tag be Repeated in a Catalogue (Y/N) Y 

Is the Tag an Authority that is only used in 1 

Catalogue (Y/N) 

N 

Keyword Search Code <leave blank> 

Default Catalogue Show Sequence 85600 

Allow Tag Xrefs with these comma sep list 856 

c. Click the F3 Update button to save the tag definitions 

5. You will also need to check/create subfields for the 856 tag: 

a. Highlight the 856 Tag  

b. Click the F7 SubF button- the Tag Subfields table will display: 

 

c. Add an (u) and (z) subfield as shown in the table below 

d. Click the F3 Update button when complete 

HEADING DETAILS 

Subfield  u z 

Subfield Description URL Descriptor 

Can be Repeated (Y/N) Y Y 
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Authority (Y/N) Y Y 

Used In Search Key (Y/N) Y Y 

Used In Marc Display (Y/N) Y Y 

Create Keywords (Y/N) N N 

Seq No 10 20 

Also Create Tag <leave blank> <leave blank> 

Also Create SubF <leave blank> <leave blank> 

The 856 tag has now been configured. 

Authority – Marc Take-Up 

In many cases Marc records are available from vendors to download into Amlib using Marc Take-Up.  

In most instances, users would select the option in Marc Take-Up to bring a Catalogue AND 

Stockitem into the system. 

You are now ready to load the e-book or audiobook Marc (.mrc) file into Amlib via the normal Marc 

Take-Up window: 

1. Launch the Amlib client 

2. Go to Main > Authorities > MarcTakeUp – the Marc Import screen will open 

3. Click the F1 Open button – the Open dialogue box will display 

4. Navigate to your E-book (containing data from OverDrive, Bolinda, etc.) folder and select the 

relevant .mrc file 
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5. Once the file name has been located, use your mouse to highlight it and click on the Open 

button – the Marc Import – Open dialogue box will then display: 

 

6. Complete the options using the above table: 

d. Marc Options = Bibliographic Data 

e. Open and Update = ticked, unless you want to view each individual MARC record 

f. Load Range = All (unless the file sizes are quite large) 

7. Click the OK button – the Bibliographic Options screen will then display***: 
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8. Ensure the following Marc Details are selected: 

g. Each bibliographic record contains =Full Catalogue & Stockitem data 

h. When displaying the records show = All tags in file 

9. Complete the following Item Defaults: 

i. Form = type in an applicable Stockitem Form Code – for example: EBK 

j. Location = an applicable location code – for example: SLIB 

k. Stats Code = an applicable Stockitem Stats Code – for example: SFIC  

l. Floor Location = could be useful to have a specific Floor Location – for example: 

Overdrive 

10. Click on the OK button when complete 

11. For users, who didn’t tick the Open and Update option box at step 6 above, then the 

following Marc Import screen will display: 

a. Review and alter the Marc record as required using the Insert, Update, Delete, 

Modify and Restore buttons along the right-hand side of the screen 

b. Click the F3 Update button when complete 
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12. The Update Options window will then display, where Cat(alogue) and (Stock)Item Options 

can be selected: 

 

13. Cat Options: When an incoming Catalogue is match with an existing Catalogue: 

m. Replace the existing Catalogue = marked 

14. Item Options: When an existing Catalogue is replaced all existing Stockitems: 

n. Are refreshed except lines: 6 

15. Click the OK button when complete 

16. A Saved Files screen will then display – enter the Saved File names to be used for the new e-

books: 
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17. Type the names of the files into which all the newly created Catalogues, Authorities and/or 

Stockitems will be saved. If you do not want to check new items – for example: Authorities, 

do not enter a filename 

18. Click the OK button 

19. The Marc file will then be imported 

Would you like to see a list of the imported records? 

1. Open the Authority, Catalogue or Stockitem module(s) 

2. From the menu, select File > Display File – the Saved Query Results screen will display: 

 

3. Highlight the filename and click the F9 Select button 

4. A List of imported items will then display 

*** If your import failed to automatically create a set of stockitem records (and the We think this file 

contains field on the Bibliographic Options – Open & Update screen displayed US AOL, then it is 

probable that your Marc Import Definitions need changing – see Marc Import Definitions (below) for 

more information. 

Stockitems 

 Think about how the Stockitems will be held: 

 Item No (Barcode) – STOCK barcodes generated by Amlib 

 Form – Create new Form code – (ABK) Audiobook and (EBK) E-book (see below) 

 Stats Code – Create New Stats codes?? 

 Floor location or Location to indicate that are for downloading rather than to select 

from the shelves – for example a new Floor or Location of OVERDRIVE 

 Set up would be similar to ClickView items 
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Form & Stats Codes (Optional) 

It is possible to enter a unique Form (Format) code to be used with the e-book and audiobook 

records 

1. Go to Main > StockItems> StockitemForms – the Form Codes table will display: 

 

2. You can add one as follows: 

a. Click the F1 New or F2 Insert button 

b. Fill in the fields as shown in the table below: 

HEADING DETAILS 

Form EBK 

Description E-Book 

Allow Loan N 

Floating? N 

Cat def Defined <leave blank – will auto-complete> 

c. Click the F3 Update button when complete 
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NetOpacs Display 

The NetOpac can be altered to give information about the records: 
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Other Things to Consider 

If a new Form code or Stats code (or both) are used it is possible to set an Opac Description (which 

will display in the NetOpacs) the Opac Form Descriptions: 

 Main > Supervisor > Opacs > OpacFormDesc 

 

Ensure the 856 Tag is included on the Marc Tags Within the System screen: 

 Supervisor module: LibraryMenu > Opacs > OpacDisplayTags 

 

  



School Tasks in Amlib 

 

 

Last Updated: 9 August 2011 
Version: 5.3 
Date of Version: 9 August 2011 
 Page 74 

Marc Import Definitions 

1. Launch the Amlib client 

2. Open the Authorities module  

3. Go to Application > MarcItemDefs – the Marc Import Definitions screen will display: 

 

4. Select the Import Orders tab 

5. Ensure the AOL Number (Mandatory) is not 001 

6. If it is 001, the change it to 955 

7. Click the F3 Update button when complete 

What you may like to discuss with your E-book/Audiobook Vendors 

o. How many titles can a Borrower have at the same time? 

p. How long will a Borrower get to keep the Titles checked out for? 

q. How do they “return items”? 

r. Can they renew the items I have checked out? 

s. What happens when they place a title on hold? 

t. How many items can they place on hold at the same time? 

u. When a hold becomes available for check out, how long do they have to check out 

the title before the hold expires? 

v. When the title is available for you, how will they be contacted? 

w. How do they cancel a hold? 

x. How do they change the email address that I entered when I placed a hold? 

y. How do they rate titles? 

z. If a new library card number is issued what needs to happen? 
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Adding Additional URLs to an Existing Catalogue Record 

It is possible to add in a secondary URL to a Catalogue record with an existing URL. 

1. Launch the Amlib client 

2. Go to Main > Catalogue > Catalogue (or the  icon) – the Catalog screen will display 

3. Locate the item to be modified using F5 Query: 

 

4. From the menu, select Catalogue > Catalog Modify using Worksheet – the Work Sheet 

screen will display 

5. To enter additional 856 (URLs) tags, click the F2 Insert button – the Select For Creation table 

will display: 

 

6. Scroll down to the 856 | Electronic location and access tag and double-click (or select and 

press <enter>) it to select it – the new 856 tag will appear in the Work Sheet 

7. Add the following data: 

a. 1 - u | URL 

b. 2 - z | Descriptor – for example: Click here for alternative link 



School Tasks in Amlib 

 

 

Last Updated: 9 August 2011 
Version: 5.3 
Date of Version: 9 August 2011 
 Page 76 

 

8. When the record is complete, click the F3 Save button – a prompt will display with the 

following message: Some new Authorities will be created. Continue with Save? 

 

9. Click the Yes button 

Editing of the Catalogue record is now complete. 

The additional URL should now display in the NetOpacs: 
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CLICKVIEW 

What is ClickView? 

ClickView is a solution for providing on-demand access to a school’s video library wherever learning 

is taking place.  

Whether from a Windows PC, Mac, TV or web page, students and teachers can view any video from 

the entire library, at any time, at their own pace, in DVD-quality.  

ClickView can be scaled to deliver video to hundreds of users at the same time across an existing 

network. It can also seamlessly integrate with a school’s online applications, including library 

catalogues and learning management systems. 

 For more information on ClickView refer to: http://www.clickview.com.au 

Integration with Amlib Library Management System 

Integration between Amlib and ClickView has been provided in Amlib Version 5.2+ and includes the 

following features and benefits: 

 Amlib converts XML export from ClickView (with details of programs, etc.) into a standard 

Marc21 format file for easy import into the Amlib database as Catalogue and Item records 

 Users can use the Amlib NetOpacs module (web-based search module) to search all materials 

stored within Amlib including ClickView records in a single search 

Even though ClickView includes the entire ClickView catalogue each time the XML export is 

generated, Amlib provides the facility to match ClickView records previously imported - so that 

schools do not need to delete existing ClickView records whenever importing the latest ClickView 

XML file. 

NetOpacs 

 Amlib can connect the Overdrive web site using a SIP2 connector and therefore validate 

membership to the library with use of barcodes via the NetOpac Interface 

 Contact Amlib Support for further information about Amlib and SIP2 connections 

 

http://www.clickview.com.au/
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CLICKVIEW IMPORT CONFIGURATION & PROCESS 

A special function has been written to enable sites to load ClickView XML data. The function is found 

in the raissue.exe application supplied in the Amlib folder on the Amlib server. This application has 

been amended to read ClickView XML files. Using the ClickView XML file, a MARC file can be created 

which can then be imported into Amlib using the normal Marc Take Up process.  

Amlib Client Configuration Settings 

979 Marc Tag 

Ensure the 979 – ClickView ID Authority tag has been defined: 

1. Launch the Amlib client 

2. Go to Main > Authorities > MarcTags – the Marc Tags Within the System table will display 

3. Check to see if the 979 | ClickView ID tag is in the list of tags (it may be also be called 979 | 

Video ID) 

4. If it is NOT present, then you can add one as follows: 

a. Click the F1 New button 

b. Fill in the fields as shown in the table below: 

HEADING DETAILS 

Tag No  979 

Tag Description ClickView ID or Video ID 

Default Ind 1 <leave blank> 

Default Ind 2 <leave blank> 

Can the Tag be Repeated in a Catalogue (Y/N) N 

Is the Tag an Authority that is only used in 1 
Catalogue (Y/N) 

Y 

Keyword Search Code <leave blank> 

Default Catalogue Show Sequence 97900 

Allow Tag Xrefs with these comma sep list 979 
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c. Click the F3 Update button to save the tag definitions 

5. You will also need to create a Subfield for the 979 tag: 

a. Highlight the 979 Tag that you have just created 

b. Click the F7 SubF button- the Tag Subfields table will display: 

 

c. Add an (a) subfield as shown in the table below: 

d. Click the F3 Update button when complete 

The 979 tag has now been configured. 

  

HEADING DETAILS 

Subfield  a 

Subfield Description ClickView Video ID 

Can be Repeated (Y/N) Y 

Used in Search Key (Y/N) Y 

Used in Marc Display (Y/N) Y 

Create Keywords N 

Seq No 10 

Also Create Tag <leave blank> 

Also Create SubF <leave blank> 
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856 Marc Tag 

Ensure the 856 – URL Authority tag has been defined, and that there is u and z subfields. 

6. Launch the Amlib client 

7. Go to Main > Authorities > MarcTags – the Marc Tags Within the System table will open 

8. Check to see if the 856 | Electronic location and access tag is in the list of tags (it may be 

also be called 979 | URL Link) 

9. If it is NOT present, then you can add one as follows: 

a. Click the F1 New button 

b. Fill in the fields as shown in the table below: 

HEADING DETAILS 

Tag No  856 

Tag Description Electronic Location and 

Access 

Default Ind 1 <leave blank> 

Default Ind 2 <leave blank> 

Can the Tag be Repeated in a Catalogue (Y/N) Y 

Is the Tag an Authority that is only used in 1 

Catalogue (Y/N) 

N 

Keyword Search Code <leave blank> 

Default Catalogue Show Sequence 85600 

Allow Tag Xrefs with these comma sep list 856 

 

c. Click the F3 Update button to save the tag definitions 

10. You will also need to check/create a Subfield for the 856 tag: 

a. Highlight the 856 Tag that you have just created 
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b. Click the F7 SubF button- the Tag Subfields table will display: 

 

c. Add the (u) and (z) subfields as shown in the table below: 

 

d. Click the F3 Update button when complete 

The 856 tag has now been configured. 

  

HEADING DETAILS 

Subfield  u z 

Subfield Description URL Descriptor 

Can be Repeated (Y/N) N Y 

Used in Search Key (Y/N) Y Y 

Used in Marc Display (Y/N) Y Y 

Create Keywords N N 

Seq No 10 20 

Also Create Tag <leave blank> <leave blank> 

Also Create SubF <leave blank> <leave blank> 
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Set the Barcode for Import 

To load the items into Amlib with the ClickView barcode, the Authority Marc Definition table will 

need to be set up. This will only have to be done once. It will then be set for subsequent ClickView 

imports. 

1. Launch the Amlib client 

2. Open the Authorities module, and select Application > MarcItemDefs – the Marc Import 

Definitions table will display 

3. Ensure the Import tab is selected: 

 

4. Check to see if the Barcode (Mandatory) line has a definition. If this is set (for example: from 

a conversion) this does not need to be changed. The program will find it and locate the 

correct definitions. If the window is completely empty, you will need to define a tag for the 

Barcode. 

5. If it is NOT present, then you can add one as follows: 

a. Fill in the fields as shown in the table below: 

HEADING DETAILS 

Description  Barcode (Mandatory) 

Tag No 945 

Subfield i 

Starting Position 0 

Length (zero for unlimited) 0 

b. Click the F3 Update button when complete 

The Barcode has now been configured. 
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 Supervisor Installation Parameters 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation screen will display 

3. Select the Catalogue tab: 

 

4. In the A Marc record exists if one of the following tags match parameter, check/add the 979 

tag – this will ensure that the catalogue records will merge if the same ClickView record is 

imported again 

5. Exit and restart the Amlib client for the settings to take effect 

The Installation parameters have now been configured. 

Check Digits 

Please Note: It may be necessary to set up a new Check Digit for ClickView items. 

1. Launch the Amlib client 

2. Go to Main > Supervisor > CheckDigits – the Check-digit Calculations table will display: 
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3. Click the F1 New or F2 insert button 

4. Enter the following settings: 

a. (I)Item (B)Bor = I 

b. Leading Chars = CVR 

c. Trailing Chars = ### 

5. Click the F3 Save button when complete 

The Check Digit parameters have now been configured. 

Form & Stats Codes (Optional) 

It is possible to enter a unique Form (Format) code to be used with the ClickView records 

1. Go to Main > StockItems> StockitemForms – the Form Codes table will display: 

 

2. You can add one as follows: 

a. Click the F1 New or F2 Insert button 

b. Fill in the fields as shown in the table below: 

HEADING DETAILS 

Form DVI 

Description Digital Video 

Allow Loan N 

Floating? N 

Cat def Defined <leave blank – will auto-complete> 

c. Click the F3 Update button when complete 

The Form Code has now been configured. 
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Converting ClickView XML Export to Marc21 

Please Note: If any errors occur whilst using any XML facility in Amlib (for example: Supervisor 

spreadsheet export, rasissue, ClickView import) the user needs to have Microsoft MSXML4.0 

installed. 

This can be downloaded from: 

http://www.microsoft.com/downloads/details.aspx?familyid=3144b72b-b4f2-46da-b4b6-

c5d7485f2b42&displaylang=en 

Before you begin:  

 Export your XML file from ClickView 

It may be useful to create a ClickView folder for these files, to make it easier to locate when 

importing them into Amlib Marc Take Up. 

1. Using Windows Explorer, locate the Amlib folder on your Amlib server 

2. Find the raissue.exe application and double-click on it to open 

 

3. From the menu, select File > Login... – the Login screen will display 

4. Type in your system administration Login name: and Password: – this is usually 

SYSADM/SYSADM 

5. Select the relevant database from the Connect To: Database: drop-down: Live or Test 

http://www.microsoft.com/downloads/details.aspx?familyid=3144b72b-b4f2-46da-b4b6-c5d7485f2b42&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=3144b72b-b4f2-46da-b4b6-c5d7485f2b42&displaylang=en
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6. The Main DB:, Cat DB: and Param DB: fields will display the corresponding databases (this is 

usually AMLIB, AMCAT and AMLOCAL for the Live database and TELIB, TECAT and TELOCAL 

for the Test database) 

  

7. From the main menu, select Conversions > ClickView > XMLCatalogue – the Convert Tag 

screen will display 

 

8. The default Tags will be defined 
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9. Check to see if the Tags have been assigned correctly – for example: Video Description may 

need to be 520 at your site (but MUST be a Non-Authority Tag) 

 

10. When set correctly, select the OK button to continue – the ClickView Library Server browse 

window will display 
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11. Navigate to the location of your saved exported ClickView.XML file 

12. Highlight the file and select the Open button 

13. You will then be asked to create a destination file (which is where the converted XML data 

will be saved) - this file will have a .MRC extension (Files of type: Marc Data) 

 

14. Click on the Save button – the conversion will then take place 

15. The following message will display on completion: Xml Conversion complete XX catalogues 

created. You may now use the output file in an authority marc take up – where XX 

represents the number of records converted: 
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Loading ClickView Marc21 File into Amlib 

You are now ready to load the ClickView Marc file into Amlib via the normal Marc Take-Up window. 

20. Launch the Amlib client 

21. Go to Main > Authorities > MarcTakeUp – the Marc Import screen will display 

22. Click the F1 Open button – the Open dialogue box will display 

23. Navigate to your ClickView folder and select the previously converted file 

 

24. Once the file name has been located, use your mouse to select it and click on the Open 

button – the Marc Import – Open dialogue box will display: 
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6. Complete the options using the above table: 

aa. Marc Options = Bibliographic Data 

bb. Open and Update = ticked, unless you want to view each individual Marc record 

cc. Load Range = All (unless the file sizes are quite large) 

2. Click the OK button – the Bibliographic Options screen will then display 

3. Ensure the following Marc Details are selected: 

a. Each bibliographic record contains =Full Catalogue & Stockitem data 

b. When displaying the records show = All tags in file 

4. Complete the following Item Defaults: 

a. Form = type in an applicable Stockitem Form code (see step 5 above) – for example: 

DV 

b. Location = an applicable location code – for example: WEB 

c. Stats Code = an applicable Stockitem Stats code – for example: NF 

 

5. Click on the OK button when complete 
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6. An Update Options window will then display, where Cat(alogue) and (Stock)Item Options can 

be selected: 

 

7. Cat Options: When an incoming Catalogue is match with an existing Catalogue: 

a. Replace the existing Catalogue = marked 

8. Item Options: When an existing Catalogue is replaced all existing Stockitems: 

a. Are refreshed except lines: 6 

9. Click the OK button when complete 

10. A Saved Files screen will display: 

 

11. Type the names of the files into which all the newly created Catalogues, Authorities and/or 

Stockitems will be saved. If you do not want to check new items – for example: Authorities, 

do not enter a filename 

12. Click the OK button 

13. The MARC file will then be imported 
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Would you like to see a list of the imported records? 

5. Navigate to the Authorities, Catalogue or Stockitem modules 

6. From the menu, select File > Display File – the Saved Query Results table will display: 

 

7. Highlight the filename and click the F9 Select button 

8. A List of imported items will then display 
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COVER IMAGES DOWNLOADED FROM SCIS 

SCIS (Curriculum Corporation) now have cover images available. The images.zip file contains images 

for items matched in the Order file (Please Note: Not all SCIS records have cover images). 

 The Images.zip file can be saved, extracted and attached to the Catalogue data in Amlib as an 

Image attachment. 

 The name of each image is the ISBN which will assist when uploading into Amlib. 

 The image is not part of the Marc file so the image will need to be added individually after 

the Marc file has been downloaded. 

Obtaining Images from SCIS 

1. Import Orders from the SCIS webpage in the usual way.  

 

2. The additional images.zip will appear in the COVER IMAGES/Get Images column. You can 

open it to see how many records have images. In this example, five records were ordered 

from SCIS, 3 have images and 2 do not contain image files. 

 

3. Save the images.zip file in a folder in a location you are able to access later  
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4. After downloading, right-click on the filename and Extract to current folder 

 

5. Import the SCIS Marc (.mrc) file using Marc Take-Up in the usual way 

Attaching Images to Amlib Records 

1. Find one of the Catalogue records recently uploaded (for example: from the Catalogue Saved 

File) 

2. Check to see that there is an image for that ISBN 
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If an image exists, you are able to attach it: 

3. From the menu, select Catalogue > Picture Sounds – the Catalogue Media screen will display: 

 

4. Click the F1 New button – navigate to the location of the saved images downloaded earlier: 

 

5. Select the image with the matching ISBN and click the Open button – it will be added to te 

Catalogue Media screen 

 

6. Enter the Replay Seq. for Entity (usually 10) and a Brief Description (for example: Cover 

image) 
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7. Click the F3 Save button when complete 

8. The Image can be tested by highlighting the new Image line and selecting the F7 Test button: 

  

9. Close the Catalogue Media screen by clicking on the red [X] in the top right-hand corner 

10. The Image icon should be now available on the Catalog screen 

 

11. If the images are to display in NetOpacs, the NetOpac configuration file may need to be 

changed to display images (NetOpacs/Amlib.ini). The actual Item list template may also 

need altering to include a new placeholder. Contact Amlib Support for more information. 
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CREATING MASTER/SUBSIDIARY ITEMS (KIT LOANS) 

It is possible to link stock items to one (Master) item. All the linked (or Subsidiary items) show as on 

loan when the Master is on loan. This is useful for sites that want to set up kits or videos (with 

programs catalogued separately) and do not wish to loan out the separate items independently. 

Example 1: Videos with Multiple Programs 

Title: ABC for Kids 

MASTER 

Example 2: Kits 

 

Kits can be added as a Master with Subsidiary items, or alternatively as a single item.  Use the former 

for those instances where you would like the ancillary items to be searchable on the catalogue.  

Otherwise a Memo on the stock item which lists the ancillary items would suffice. 

Creating a Master Record 

1. Launch the Amlib client 

2. Go to Main > StockItems > Stockitem – the Stockitem module will display 

3. If you are creating a new stockitem: Enter the barcode that you wish to use for circulating 

the loan. If the item is a kit or box, scan the barcode into the Item No field. Otherwise, just 

do a F5 Search in the Stockitem module to locate the item which you would like to be the 

Master Item 

HINT:  A description relating to the item as a Master can be added to assist in listing Master Items. 

SUBSIDIARY ITEMS 

 Big red car (20 mins) 

 Wiggle time (30 mins) 
 

SUBSIDIARY ITEMS 

 Teacher’s Guide Book 

 Video 

 24 plastic animals 

 Sound cassette 

 Worksheets 

 Game 
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4. From the menu, select XReferences > SelectAsMaster: 

 

5. The following prompt will then display: The Item has been selected as Master. 

 

6. Once the item has been selected as a Master, the ITEM TYPE: will change from N (Normal) 

to M (Master): 

 

7. Click the F1 Clear button – the system will remember the last item to be made a Master 

Item 

8. It is then possible to link other items to this Master Item.  You can either create a new 

stockitem record (attached to the same catalogue record), or use F5 Search to locate the 
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stockitem in question (which can be linked to the same Catalogue record – or a separate 

record if you would like it to be searchable as a unique entity). 

9. Once the stockitem to be linked is displayed on the screen, from the menu, select 

XReferences > CreateLink – a prompt will then display, asking you to confirm the Link this 

Item with the Current Master: 

 

10. Click the Yes button to create the link – the following prompt will then display: The item has 

now been Linked. 

 

11. The Stockitem will now have an ITEM TYPE: of S (Subsidiary): 
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Circulating Linked Items 

 When borrowing out linked Items, only the Master Item will display in the Issues module: 

 

 Subsidiary items can be circulated independently of the Master – the following Alert will 

display if a Subsidiary item is circulated: This is a Subsidiary item. It is not usually issued 

using its own barcode – normally the Master record must be issued. 

Do you want to issue just this item? 

 

 When the item is returned another Alert notice will display (see below for more details) 

 Once the Master Item is out on loan, all linked items also show that they are out on loan to 

that borrower.  In the Borrower module, from the menu, select XReferences > 

ShowItemsOnLoan to see the full list of items on issue to that borrower (including linked 

items): 
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 To check the Master of any Stockitem with an ITEM TYPE of S, from the Stockitem module 

menu, select XReferences > CurrentMaster – the following prompt will display denoting the 

current Master record: 

 

 To check a listing of linked items, from the Stockitem module menu, select XReferences > 

RelatedItems –a Stockitem List of Related Items will display: 

 

Returning Master-Subsidiary Items 

This procedure applies to checking in or scanning through the returns module any items that have 

been set up with a Master-Subsidiary relationship (for example, kits with several parts or boxes of 

books and other library items). 

1. Launch the Amlib client 

2. Go to Main > Circulation > Returns – the Returns screen will display 

3. Check in the box or Master item – a prompt will display with the following message: This is 

the Master Item. Return All Parts 

 

4. If you are sure that all items are present, click the Yes button (otherwise click the No button) 
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5. If you clicked the Yes button, the returned item will display in the Returns screen: 

 

6. To return only some parts of the box or set, click the No button – the Subsidiary Return 

Check screen will display: 
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7. Use the list to check if all contents are present. If not, use the options on the screen (pictured 

below) to process these items according to your library procedures: 

FIELD EXPLANATION/OPTIONS EXAMPLE 

Process Code A process code can be 

entered in this field to be 

automatically added to items 

with a Y in the Add Process? 

column. 

 

Alert If set to Y a message will 

display at issues if the item is 

checked out to another 

borrower, to alert the 

operator to the Process Code 

on the item. 

A message will appear at the issues screen to indicate that 

the item has a process code (see screen shot below). Click 

the OK button to proceed with the issue. 

OPAC If set to Y, the item will show 

on the OPAC.  

If the item is missing, setting the OPAC to N will mean that 

library users will not see the item displayed and this will 

prevent them from asking for an item that is not available. 

For Loan If set to Y, this will allow the 

item to be borrowed if 

presented at the circulation 

counter. 

For missing items or parts of a set, this may be set to N to 

stop the item from being borrowed until the process code is 

removed or the item is returned to its set. 

Memo Type Information contained in 

these fields will determine the 

memo placed on selected 

items. A Memo Type can be 

selected from the list of 

Memo Types. Additional or 

alternative text can be added 

in the Text field. 

A Memo Type of BULK LOAN may have been created and 

selected in this screen. 

 The Text may include the details of the set that was 

originally loaned out. Text 

Return? The system will check 

in/return any items with a Y in 

this column 

If items are present, they can be checked in and those not 

present are marked with an N so they remain checked out 

and undergo normal overdue processes. Alternatively, all 

items may be checked in (mark items with a Y in this column) 

and a Process Code may be used instead. 

Add Memo? A memo will be added to 

those items marked with a Y 

in this column 

A standard memo for bulk loans may be added to those 

items that are not present – to indicate what set they were 

originally loaned in, and that the parts had not been 

returned. 

Add Process? A Process Code (see above) 

will be added to any items 

with a Y in this column 

Items may have a process of ‘missing part’ to indicate on the 

catalogue that they are part of set that is now incomplete. 

8. Click the green OK button at the bottom of the screen to process the items as indicated 
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9. Items that were marked as Y for return will display on the returns screen: 

 

10. If some items were marked as N for return, these will display as on loan to the original 

borrower: 
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11. Items that were marked with a Y for Process Code, will contain the corresponding Process in 

the Stockitem record: 

 

12. If items were marked with a Y for Memo, the memo will display on the Stockitem record: 

 

 When returning a linked item, if you attempt to return the Subsidiary Item rather than the 

Master Item, the following prompt will display: This is a Subsidiary item.  It cannot be 

returned using its own barcode – the Master record must be returned. 
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Supervisor Settings 

It is possible to change the System settings so that when a Master Item is checked in via the Returns 

module, it automatically shows Subsidiary Return Check list of the Subsidiary Items: 

1. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

2. Select the Circulation tab 

3. Scroll down and adjust the following setting: Show subsidiary items when returning a master 

item (Y/N) = Y 

 

4. Click the F3 Save button 

5. Exit and restart Amlib client for the settings to take effect 

Alternate Method 

HINT:  Alternatively, you can attach a memo to the Master Item, so that a message displays with an 

indication of how many items are attached so that this can be checked: 
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Delinking Items 

 To break the link: from the Stockitem module menu, select XReferences > BreakLink – a 

prompt with the following message will display: The Item has been unlinked from ‘XXXX’ 

 

Please Note: You will be unable to delete a Master stockitem record if it has linked items. The 

Master cannot be removed as a Master until the items are first disconnected. 
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PREMIERS READING CHALLENGE 

The PRC Listmaker program compares the contents of your library system's database against the items 

contained in the Premier's Reading Challenge booklists. PRC Listmaker displays all items matched. The 

list can then be printed or exported. Exported lists can be transferred into MS Word, Excel or another 

program. Various options are included to change the sort order, level and categories viewed.  

PRC Listmaker now automatically tags items in your library catalogue that are not found in the PRC 

Booklists but which have the same series as titles that are on the booklists. 

For assistance with the PRC Listmaker program contact: 

 Email: support@librarysolutions.com.au 

 Phone: 1800 241 709 

 Fax: (03) 9469 4700 

Please Note:  DO NOT run the PRC Listmaker if you have more than one Catalogue record with the 

same ISBN in your database! 

Saving Catalogue Stockitem Records to a File 

1. Launch the Amlib client 

2. Go to Main > StockItems > StockitemWhere – the Stockitem Where Search screen will display 

3. Enter the following Where statement: 

a. Choose Column to Search select Item No 

b. Choose Operator select  ≠  (not equal to) 

c. Leave box (3) empty   

d. Click the Paste button 

 

mailto:support@librarysolutions.com.au
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Please Note: You may also want to limit the Where statement by collection – for example: 

Sts Code = JF 

4. Click the F7 QtoFile button – the Stockitem Saved Query Results screen will display: 

 

5. Click the F1 New button and give the file an appropriate Details name–  for example: 

Premiers Reading Challenge (as this is the file that will be used when exporting the data) 

6. Click the F3 Save button to save the name of the file 

7. Highlight the file and click the F9 Select button to transfer the list of items into the file 

8. A prompt will display with the following message: The ‘PREMIERS READING CHALLENGE’ file 

contains XXX stockitems. 

 

9. Click the OK button 

The Saved File is now complete. 
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Check the Export Items Definitions  

Before using Marc Export for the first time, you must check that the appropriate mapping has been 

done for Marc Export.  This only needs to be done once.  

1. Go  to Main > Authorities > Authorities – the Authorities screen will display 

2. From the menu, select  Application > MarcItemDefs  - the Marc Import Definitions screen 

will display 

3. Click on the Export Items tab 

Please Note: This table is used to set the parameters for the Export Items.  To complete an export for 

the Premiers Reading Challenge it is necessary to enter as least one Marc tag in this screen: 

specifically the barcode tag.   As seen in the example below, more tags can be defined for an export 

to different systems, however for the PRC Listmaker only the barcode is required. 

4.  In the Tag No and Subfield columns enter the tag number that Barcode will go in (see Note 

below on choosing a tag if one is not already entered): 

 

Please Note: The Marc Tag does not need to be defined on the Authority > MarcTags screen to be 

used in the Export. Usually a 9xx Tag is chosen as this is reserved as these are the Local Defined Tags.  

For example 945i or 998a are good choices. 

5. Click the F3 Update button when complete 
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Export the Records from Amlib  

1. Go to Main > Authorities > Authorities – the Authorities screen will display 

2. From the menu, select Application > MarcExport – the Marc Export screen will display 

3. Enter the following parameters: 

a. (1) Choose the Marc Export type: select  Bibliographic Export from Stockitem File 

 

b. (2) Change any options specific to the selected export type: select Write each Marc 

record on a separate line in the Export File 

 

c. Leave (3) blank 

d. (4) Select the Saved File to use in the export: click the Saved File… button – the 

Stockitem Saved Query Results screen will display: 

 

e. Highlight the Premiers Reading Challenge file and click the F9 Select button 
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f. (5) Ensure the Marc radio button is selected: 

 

g. Click the Save As… button – Marc File – Save As… screen will display: 

 

h. Select a drive to save the file to, create a file name (for example: 

PRCListmakerFile)and click the Save button 
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4. Select the F3 Start button – an Export processing prompt will display: 

 

5. When complete, a prompt with the following message will display: XXX records from the 

‘PREMIERS READING CHALLENGE’ Saved File have been exported. 

 

6. Click the OK button 

PRC Listmaker 

Download and install the PRC Listmaker client (this example uses the S.A. PRC Listmaker): 

1. Launch the PRC Listmaker client 

 

2. From the menu, select File > Compare – the Compare Library Data screen will display: 
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3. Select MARC format data (Amlib) and click the OK button 

4. Navigate to the saved .mrc file, select it and click the Open button 

 

5. A prompt with the following message will display: Do you want to tag the matched records 

in the data? 

 

6. Click the Yes button – the file will then be scanned: 

 

7. The result list will display when complete: 

 

8. Click the Exit button – an output.mrc file of tagged items will have been created in the same 

folder that the export file was saved to 
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Importing the PRC output file into Amlib  

The PRC Listmaker Compare process will produce a file called output.mrc which needs to be 

imported into Amlib.  

1. Launch the Amlib client 

2. Go to Main > Authorities > MarcTakeUp – the Marc Import screen will display: 

 

3. Click the F1 Open button to display the Open dialogue box: 
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4. Browse to where the output.mrc file is saved, select the file and click the Open button – the 

Marc Import – Open screen will display: 

 

5. Complete the options as follows: 

a. Marc Options = Bibliographic Data 

b. Open and Update = unticked 

c. Load Range = All  

6. Click on the OK button – the Bibliographic Options window will display, showing how many 

records are in the file (matched items from the PRC Listmaker): 
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7. Ensure the defaults are selected as above: 

a. Each Bibliographic record contains: Catalogue data only 

b. When displaying the records show: All tags in the file 

8. Click the OK button – the Update Options – Open and Update screen will display: 

 

9. Ensure that the Update Options are set as follows: 

a. When an incoming Catalogue is matched with an existing Catalogue: Replace the 

existing Catalogue 

b. When an existing Catalogue is replaced all existing Stockitems: Are refreshed except 

lines: 6 

10. Click the OK button – the Marc Import screen will display: 
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11. Click the F3 Update button – the Saved Files – Open and Update screen will display: 

 

12. Type the names of the files into which all the newly created Catalogues and/or Authorities 

will be saved. If you do not want to check new items – for example: Authorities, do not enter 

a filename.  

13. Click on the OK button – an Update processing prompt will display: 

 

14. Once complete, a prompt will display with the following message: Record Numbers X to XXX 

have been Updated. 

 

15. Click the OK button 

The import of the tagged PRC records is now complete.  



School Tasks in Amlib 

 

 

Last Updated: 9 August 2011 
Version: 5.3 
Date of Version: 9 August 2011 
 Page 119 

Tagged Catalogue and Stockitem Records 

1. Viewing the records in the Catalogue module shows that the asterisk is added to the title 

and the level is added as a 490 Series tag to the record: 

 

2. Viewing the item in the Stockitem module also shows the asterisk (*) and a PRC series entry: 
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STOCKITEM MAINTENANCE 

Add a New Item 

It is sometimes necessary to create a Stockitem record that is not attached to a catalogue record – 

for example: a piece of equipment. 

1. Launch the Amlib client 

2. Go to Main > StockItems > Stockitem – the Stockitem screen will display 

3. From the menu, select Item > NewItem – the New Stockitem table will display, prompting 

you to choose a Form Type for the new Stockitem: 

 

4. Select the Form Type (for example: EQ – Equipment) and click the OK button – the 

Stockitem screen will enter creation mode (with Form code selected): 
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5. Add the required details 

 

6. Click the F2 Insert button when complete 

7. If you haven’t wanded in a barcode, a prompt will display requesting if you would like to 

insert a system-generated Barcode:  

 

8. Click the Yes button – a prompt will display with the following message: The Item has been 

Inserted. 

 

9. Click the OK button 

The stockitem has been created. 
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Copies/Duplicates Items 

To enter copies of the same catalogue item: 

1. Launch the Amlib client 

2. Go to Main > StockItems > Stockitem – the Stockitem screen will display 

3. Search for the item to copy (duplicate) using F5 Query 

4. Scan in a new barcode into the Item No field – the F2 Insert button will become active 

(bolded) 

5. Change any other details as required – for example: Stats Code, Copy No and Floor location 

10. Click the F2 Insert button when complete – a prompt will display with the following 

message: The Item has been Inserted. 

 

11. Click the OK button 

The duplicate stockitem has been created. 
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Alter the Field Names Displayed for a Particular Stockitem Form Type 

Some Stockitems (particularly equipment) do not conform to the standardised labels in use by the 

system.  However, it is possible to modify the labels displayed for a particular Form type.  

1. Launch the Amlib client 

2. Go to Main > StockItems > StockitemForms – the Form Codes table will display: 

 

3. Highlight a Form – for example: EQ and select the F9 Display button – the Stock Display Tags 

screen will display: 
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4. Adjust as per the following example: 

o Line 1: Label = Equipment | Tags to Display = 245 

o Line 2: Label = Model No | Tags to Display = 300 

o Line 3: Label = Manufacturer | Tags to Display = 260 710 

o Line 4: Label = Description | Tags to Display = 500 

o Line 5: Label = Subject | Tags to Display = 650 651 600 

o Line 6: Label = Call Number | Tags to Display = 984 082 

Please Note: Tags to display should type in order of preference (the first tag containing a value will 

then display). 

 

5. Click on the F3 Save button when complete 

6. To refresh the data displayed for a particular stockitem, select Item > RefreshFromCat 

7. Click the F3 Update button to save changes 
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APPENDICES 

Appendix1: Setting Up the Option for Export from Stockitem File 

In order to have the option to export records from a stockitem file, the export item definitions 

should be filled in. Log out of the Authority module and then back in and you should have the export 

from stockitem option available in box one of the export screen. 
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Appendix 2: Check Digits 

If you change your barcodes at any time or introduce a new type of barcode, you will need to add a 

line to your check digits, so the system recognises the new barcode as being valid. 

1. Launch the Amlib client 

2. Go to Main > Installation > Supervisor 

3. From the menu, select LibraryMenu > CheckDigits – the Check-digit Calculations screen will 

display: 

 

4. Click the F1 New button to create a new line 

Columns 2 and 3 are optional. As a minimum you must specify: 

 If the barcode is for items (I) or borrowers (B) – if it is to be used for both, you will need to 

create two lines – one for each. 

 Leading characters and trailing characters – you can use these to indicate a barcode prefix or 

suffix that is the same for every barcode e.g. AL102. Otherwise you can just use the & 

symbol (see the legend at the top right of the screen). The system adds together the leading 

and trailing characters to make up the total length of the barcode. At the most basic level, 

you can just count the number of digits in the barcode and divide roughly between the 

leading and trailing columns 
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5. Click the F3 Save button when complete 

6. To test a barcode, use the test box in the top left corner, select either Item or Borrower, 

then scan the barcode into the box and click the F6 Test button 

 

For more information, press Ctrl-H from your check digits window. 

 


