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OVERVIEW 

Amlib keeps statistics to enable sites to report on System Activity for library management purposes 

and to send information to other agencies – for example: State Libraries, Councils, School 

Committees, Principals, etc. Amlib statistics can include: 

 Detailed reports of System Activity defined on the Statistics Codes table in the Supervisor 

Application – for example: Listing of Borrower Types with Loans split by Stats code 

 Summary reports of System Activity defined on the Statistics Codes table in the Supervisor 

Application – for example: Listing of all Events per month over the Year 

 Where searches: Counts of the number of currently held items and borrowers can be 

calculated and the Search saved for future use 

 Stockitem Reports: Counts with Value – for example: Count of Missing, Count of New Items, 

Count of All Items, Counts of Books, Counts of Non-Books, etc 

 Borrower Reports: Counts of Borrower by Type, Gender, etc 

 Excel Reports: From Spreadsheet parameters or special Template reports sent to File 

 System Activity: Simple Graphs on trends for Issues, Reserves, Returns and Enquiry. Found in 

Main > Supervisor > Library Menu 

 Opac Form Descriptions: Counts of Form/Stats combinations. Designed for writing user-

friendly descriptions to be observed in NetOpac and Opac but useful in checking the 

numbers. 

Amlib reports are very flexible in the data that can be selected. The essence of the reports is 

understanding how the Where parameters are defined.  Where Parameters can be altered by Amlib 

client users. 

For example, by setting the Where parameters we can determine the detail of the Issues by data 

presented: 

 the hour 

 days of a week 

 months of a year 

 for a calendar year 

 for a financial year 

There are many Statistics templates available for use with Amlib. 

Templates can be used over and over again. The Where parameters will determine the content of 

the report.  

Most Statistics reports are similar and reflect different sequencing of data. Because of the 

sequencing of data, ordering of the reports is essential. Many of the Reports have the Ordering 

assigned to the report, so that the User cannot alter it. The Order button will be grey. 
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The report chosen will determine the level of accumulation and detail. 

Statistical output is available in the Supervisor module using Activity Graphs and Spreadsheet 

parameters. Some Borrower, Stockitem and Statistical counts can be sent to a File in a form that can 

be opened in MS Excel. 

Statistics are kept on the database until deleted, so there is no urgency in getting certain reports by a 

certain time (not from the system aspect anyway!). For example: statistics can be gathered for 

January in June! (As long as you have been using Amlib that long, and that the Parameters table was 

set to collect the statistics). 

In order to use the Spreadsheet and System Activity windows you must decide which statistics are to 

be collected within the system.   

Access the Statistics Codes table from the Supervisor module:  

 Main > Supervisor > StatsParams.  

The StatsType is important and never changes – for example: Issues = 5, Renewals = 6, Returns = 10 

and Location Transfers = 20. 
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COUNTS 

Opac Form Descriptions 

This option enables the entry of “User friendly” descriptions that are seen by NetOpacs users in the 

Form column of the NetOpacs screen.  

For example, instead of the OPAC user seeing the codes of LP and AF in the Form column, a Form 

Description of Large Print Fiction can be given. 

1. Launch the Amlib client 

2. Go to Supervisor > Opacs > OpacFormDesc – the Opac Form Descriptions screen will display: 

 

Shows the numbers for Form and Stats combinations, which is useful for picking up mistakes in Stats 

or Form codes. The items can then be seen by performing a search in the Stockitem screen with the 

same combination of Form and Stats codes. 
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Where Searches 

You can access Where searches in the Stockitem and Borrower modules by selecting Application > 

Where... (in the Stockitem module) or Application > BorrowerWhere (in the Borrower module) 

 

1. Choose Search column: it can be helpful to have a look at the main Stockitem (or 

Borrower) screen if you’re confused about which fields contain what information 

2. Choose Operator: these are the same as in the Reports module 

OPERATOR DESCRIPTION EXAMPLE 

LIKE Where the required data in this field 

begins with the text entered 

LIKE ELD (for Eldorado) 

LIKE Where the required data in this field does 

not begin with the text entered 

LIKE ELD (for all except Eldorado) 

IN Useful for selecting multiple codes IN A,J,YA (for all of these types) 

IN Useful for multiple codes not to be 

included 

IN ILL,LS (to exclude these types) 

= Where the text entered is exactly equal to 

the data required 

= A (borrowers with a code of A for 

Adult) 
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 Where the text entered is not equal to the 

data required 

Useful for NOT EQUAL TO NULL – choose 

this operator, do not enter any data and 

click the Paste button 

 J (borrowers who do not have a 

code of J) 

< Where the text entered is less than the 

data required 

< 01/10/10 (less than 1 Oct 2010) 

< Where the text entered is equal or less 

than the data required 

< 01/10/10 (less than or equal to 1 

Oct 2010) 

> Greater than >01/10/10 (greater than 1 Oct 2010) 

> Equal or greater than the text entered > 01/10/10 (greater than or equal to 

1 Oct 2010) 

3. Type the Where condition: this can be a date, a code, letters, numbers, etc 

BUTTON DESCRIPTION 

Paste Adds the Where condition to the Query Description table 

Special This button contains useful fields that can be used for any mathematical operand (i.e. , , 

, , , ) – for example: Current Date 

Delete Deletes the highlighted Where condition from the Query Description table 

AND Includes the AND separator to the Where conditions in the Query Description table (this is 

the default) 

OR Includes the OR separator to the Where conditions in the Query Description table 

( Adds a beginning bracket to the Where condition in the Query Description table 

) Adds a closing bracket to the Where condition in the Query Description table 

4. Once your Where condition is set up you can either: 

a. Count the number of results using the F6 Count button 

 

b. Get the list of results using the F5 Query button 
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5. If you wanted to find ALL of something (for example: Borrower, StockItems, items on 

loan) then you could run a query such as: 

a. BarCode IS NOT NULL (all Borrowers) 

b. ItemNo IS NOT NULL (all StockItems) 

c. Issue Due Date Back IS NOT NULL (all items on loan) 

 

The NULL value is achieved by simply leaving a blank space in the field 3 Type the Where Condition 

and Press Paste – as soon as the Paste button is clicked a NULL value is entered into the Query 

Description table. 

Special Button 

The Special button can be used for a number of things including the creation of relational dates 
(dates that aren’t fixed but operate from the concept of a Current Date or the Start of Month). 

For example: if you would like to look at dates from a week ago or further back, you could enter the 
following Where condition:  

 Issue Date Due Back <= Current date – 7 Days 

1. Select Issue Date Due Back from the 1 Choose Search Column box 

2. Select the < operand from the 2 Choose Operator box 

3. Click the Special button – another Where prompt will display 

4. Select the Special operand from the table – for example: Current Date 

5. Adjust the relational value of the selected operand by using the + or – buttons and the Days 
or Months boxes – for example: - 7 Days 
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6. An example of the expressed condition will be visible in the box at the top of the prompt: 

  

7. Click the Paste button when complete 
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Saving a Where Search 

It is possible to save a Where search: 

1. Click the F2 Insert button – the Saved Queries screen will display: 

 

2. Type in a Description and select the F3 Save button – a prompt will display with teh following 

message: The Query File has been created. 

 

3. Once saved, you can access saved Where search by clicking the F4 Select button in the 

Where screen, selecting the Saved Query from the list and then clicking the F9 Select button 
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Query to File 

It is possible to save the Where search results to a file, which can then be used in other operations 

(including reports). 

1. After choosing your Where parameters, select the F7 QtoFile button – the Saved Query 

Results screen will display: 

 

2. You can either use a pre-existing list file or create a new list file:  

a. To use a pre-existing file: select a list entry from the table and click F9 Select (click F2 

Empty first if you would like to clear any pre-existing list items – look at the Qty 

column to ascertain this) 

b. Alternatively, a new file can be added by: clicking on the F1 New button, typing in 

the Details (for example: Chelsea Junior Fiction) andthen clicking on the F3 Save 

button. Then highlight the file and click on the F9 Select button. 

3. This Saved File can now be used as part of a report or procedure 
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REPORTS THAT PRODUCE COUNTS 

RepBorrower 

 Borrower Type Counts by Location & Gender and Suburb & Location: &BCT.QRP   

 

 Borrower Type Counts for schools: &BCTSCH.QRP  

 

 

 Count by Location, Suburbs, Wards: &BCLTSWA.QRP 

 

RepStockitem 

Count by Stats Code – for example: State Library of Western Australia Statistics 
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 &STKCS.QRP 

 Report Type: Stockitems (Default) 

 

Count by Form and Stats Code 

 &STKCFS.QRP 

 Report Type: Stockitems (Default) 

 

Count by Stats Code and Call Set 

 &STKCSC.QRP 

 Report Type: Stockitems (Default) 

 

Count with Excel 

 &XSTKFS.QRP 

 Report Type: Stockitems (Default) 
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Send to excel the count by Form code 

 

Stock Usage  

There are four (4) reports that count usage of stockitems: 

 &STKHCSC.QRP – Stats code order giving details of each Stockitem 

 &STKHCSS.QRP – Stats code order giving a summary only 

 &STKHCC.QRP – Call number order giving details of each Stockitem 

 &STKHCCS.QRP – Call number order giving a summary only 

 Report Type: Item History 

These can be set to report ISSUES by adding to the Where parameters: History Type LIKE ISS  

 

Summary by Stats Code 

 &STKHCSC.QRP (based on History Dates) 
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Details of Usage by Stats Code with Title, Barcode 

 &STKHCSC.QRP (based on History Dates) 

 

Summary by Call Number 

 &STKHCCS.QRP (based on History Dates) 

 

Details of Usage by Call Number with Title, Barcode 

 &STKHCC.QRP (based on History Dates) 
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Stockitem Average by Stats 

 &STKAVG.QRP 

The report shows the average cost of an item, the average issues of an item, the average renewals of 

an item, the average usage of an item (issues and renewals together) and the average year that an 

item was added to the library’s collection (all by Stats Code). 
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High Usage 

There are several report templates to count high Stockitem usage. The report templates are 

designed to show items used more than 5, 10 or 20 times within a specified period (using the F7 

Where statement). The report templates will list the title and the number of times used. 

 &STKH5.QRP – Shows items where count > 5 

 &STKH10.QRP – Shows items where count > 10 

 &STKH20.QRP – Shows items where count > 20 

The reports are run against the Stockitem History. Users that delete data from the Stockitem History 

table need to be aware of the limitations of results. 

Create Report 

1. Launch the Amlib client 

2. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display 

3. Click the F1 New button – the Select Report Format screen will display 

4. Highlight the Stockitem History report template you would like to use – &STKH5.QRP (Usage 

Count > 5), &STKH10.QRP (Usage Count > 10) or &STKH20.QRP (Usage Count > 20). 

5. Click the Select button 

6. Type in a Description – for example: Usage Count > 5 Issues 

7. Ensure the Create Fin (Y/N) column is set to N 

 

8. Click the F3 Save button 

Where Search and Order By Parameters 
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1. Highlight the report and select the F7 Where button – the Stockitem Reports – Where screen 

will display 

2. Enter the following Where search: 

a. History Type = ISSUE 

You can use ISSUE, RENEW OR RETURN 

(Use the Paste button to insert the parameter into the list at the bottom of the 

screen) 

b. If using History Type = Issue, you may want to exclude any alterations made to the 

due date after renewals: History Contents NOT LIKE Due Date Altered 

c. Enter a start date: History Date >= enter a date in DD/MM/YYYY format – for 

example: 01/01/2010 

d. Enter a finish date: History Date <= enter a date in DD/MM/YYYY format – for 

example: 10/10/2010 (a finish date is optional – if not inserted, the report will go up 

to the current date). 

e. You may want to add other restrictors – for example: Borrower No = 

 

3. Click the F3 Save button when complete – this will close the Stockitem Reports – Where 

screen and return you to the Stockitem Reports screen 
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4. Click the F9 Order button –the Stockitem Reports – Order By screen will display: 

 

5. Select Item No from the Columns list and arrow it across into the Order By list 

6. Click F3 Save – this will close the Stockitem Reports – Order By screen and return you to the 

Stockitem Reports screen 

View Report 

1. Highlight the report you wish to run and click the F8 View button 

2. The following prompt will display: This type of report may use a Saved File as the Source.  

Do you want to select the file now? 

 

3. If you would like the report to run using the entire database (rather than a Saved List) then 

click the No button 
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4. The report will then display: 

 

5. Select the print button to print the report 
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STATS PARAMETERS 

The Statistics that Amlib collects are selected from the Statistics Code table in the Supervisor module.  

1. Launch the Amlib client 

2. Go to Main > Supervisor > StatsParams – the Statistics Code table will display: 

 

Please Note: You may change the Stats Descriptions and collection flags for any of these items but 

you may not alter the Stats Type code itself – for example: 5 is always an issue even though you may 

give it a description of “loan” rather than “issue”. The Circulation module has been set to add 1 to 

the 5 Stats Type every time an issue is made. 

Because statistics are kept by the actual day month and year values, maintenance of statistics (for 

example: indexing) is not required and you do not need to print monthly stats at the exact end of 

month. For example: you can print stats for July in December if you so desire. 

Some statistics are kept by Location and some are not recorded. For example: Catalogue and 

Periodicals records are not kept by location. Stockitems and Circulation would however be kept 

according to location. 

Statistics are kept on the database until deleted. 
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STATS 

TYPE 

STATS 

DESCRIPTION 

EXPLANATION 

04 Foreign Issues All issues from locations other than the Login Location 

05 Issues (Loans) All issues from the Circulation, Issues screen 

06 Renewals All renewals, including single and multiple renewals from the Issues screen 

07 Borrower Visits Every time a borrower’s barcode is wanded (has a transaction) in Amlib – either 

from Issues or Reservation (Borrower OPAC visit is collected separately) 

10 Returns All returns, including Chute Returns, Returns screen, Issues screen returns 

11 Foreign Returns All returns from locations other than the Login Location 

13 Returns Not on 

Loan 

All returns where the Item being returned was identified as being Not On Loan 

15 Reservations All reservations made from the Reservation application (OPAC Reservations are 

collected separately) 

16 Satisfied 

Reserves 

Reservations that have been satisfied on the issue of the item to the borrower 

who has had the reservation on the item 

17 Expired 

Reserves 

Reservations that have passed the expiry date set up in Main > Supervisor > 

Installation – Circulation tab 

18 Cancelled 

Reserves 

Reservations cancelled by an operator (OPAC Reservation cancellations are 

collected separately) 

19 Foreign Reserve Reservations made from any other location other than the Login Location 

20 Location 

Transfers 

All Permanent and Temporary Location transfers using the Main > Circulation > 

Transfers screen for outgoing Transfers 

22 Location 

Transfers IN 

All Permanent and Temporary Location transfers using the Main > Circulation > 

Transfers screen for incoming Transfers 

25 InHouse Circ Stockitem has been wanded in the Circulation module In House Processing 

screen 

26 Bookings Item has been reserved using the Bookings screen 

27 Satisfied 

Bookings 

Bookings made have been  

28 Cancelled 

Bookings 

Bookings cancelled by an operator (OPAC Booking and NetOpac Booking 

cancellations are collected separately) 

29 Expired 

Bookings 

 

30 New Orders All orders using the Order Application as well as AOL import 

31 Del. Orders All orders that were deleted 

35 New Periodicals All Master/Main Entry Periodicals newly created in the Periodical module 

36 Del. Periodicals All Deleted Periodical Masters/Main Entries 
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41 New Per Copies Periodical copies received from the Periodical module 

42 Del. Per Copies Periodical copies deleted from the Periodical module 

50 All Enquiries All Enquiries made from the Borrower Details, Stockitem or Catalog screens 

(OPAC and NetOpac Enquiries are collected separately) 

51 Opac Author 

Enq 

All searches performed through the OPAC screens, corresponding to the type of 

search shown in the Description. This does not include NetOpac searches (these 

are kept separately in the 500s Statistic parameters) 
52 Opac Title Enq 

53 Opac Subject 

54 Opac All 

Keywords 

55 Opac 

Periodicals 

56 Opac Borrower Any time that a Borrower has entered their barcode to look at Borrower Details 

from the OPAC screen 

57 Opac Reserves Reserves – only made from the OPAC screen. Does not include Reservations 

made from the Reservation module 

58 Opac Renewals Any renewal made via the OPAC screen. Does not include Renewals made from 

the Circulation module 

61 Borrower 

Enquiries 

Queries performed from the Borrower module for Borrower Details 

62 Stock Enquiries Queries performed from the Stockitem module for Stockitem Details 

63 Catalogue Enq. Queries performed from the Catalogue module for Catalogue Details 

64 Authority 

Enquiries 

Queries performed from the Authority module for Authorities 

80 New Borrowers New borrowers manually entered onto the database (does not include Borrower 

Import) 

81 Del. Borrower Borrowers deleted from the database either individually or as a Borrower Mass 

deletion 

82 Reregister Borrowers who have been re-registered 

83 Updated Borr. Borrowers who have had their details changed in some way by an operator and 

these changes have been saved (does not include Mass Borrower Change) 

90 New Items New Stockitems created manually (Items created through an exchange are 

collected separately)  

91 Del. Items Stockitems deleted from the database either individually or as a Stockitem Mass 

Deletion 

93 Updated Items Stockitems which have had their details changed in some way by an operator 

and these changes have been saved (does not include Mass Stockitem Change) 

94 New ILL Items ILLs created in the ILLs screen of the Stockitem module 

95 Del ILL Items Stockitems deleted that were created from the ILLs record of the Stockitem 
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module 

96 New Order 

Items 

(Received) 

New orders received in Order module. Subset of New Items, so counted in that 

Statistic as well (90). Statistic gets  created as soon as the Order Line Item is 

received 

97 Del Order Items Order items deleted from Order module 

98 New Order 

Placed 

New Orders items created in the Order module. Statistic is created as soon as the 

Status is changed to Ordered 

100 New Cats New catalogues created manually  

101 Del. Cats Catalogue records deleted from the database either individually (via the 

Stockitem or Catalogue modules) or as a Stockitem Mass deletion if set to delete 

Catalogue entries if the StockItem is the last for the catalogue 

103 Upd Cats Catalogues which have had their details changed in some way by an operator 

and these changes have been saved 

110 Cats via MaRC New catalogues created via the Marc Import process 

111 Items via MaRC New Stockitems created through an exchange, that has been configured to 

create Stockitems as part of the Marc Import process 

112 Orders via 

MaRC 

New orders created through the AOL import process (this would only be valid for 

WA LISWA sites) 

113 Auths via MaRC New authorities created via the Marc Import process 

114 Bumps Cats via 

MaRC 

Any catalogue that has been automatically replaced via the Bump facility in the 

Marc Import process 

200 Opac Other Users who have used the OPAC Other function in OPAC (usually F10) 

201 Other #1 Users who have used the Opac Other function in OPAC (usually F10), which can 

be specified e.g. #1 may be Word facility, #2 may be linking to the Internet etc. 

(These need to be set in the parameters in the Main > Supervisor > Opacs > 

OpacOther screen – first column Sequence refers to the Stats collection code 

and a corresponding entry in the Statistics Codes table) 

203 Other #2 

204 Other #3 

300 Borrower 

Reports 

Borrower reports that have been run (if there is a Stats Code entered for that 

report in the Report Stats Code and a corresponding entry in the Statistics Codes 

screen) 

310 1st Overdue These are user-defined Stats codes. Circulation reports that have been run (if 

there is a Report Stats Code entered for that report and a corresponding entry in 

the Statistics Codes table). Statistics on the number of individual notices 

generated can be gained by adding in a Detail Stats Code (where applicable). 

310, 311, 312, 313 are examples. 

311 1st Overdue Cnt 

312 Final Overdue  

313 Count Final 
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500 WebAuthor Searches performed via the 

NetOpacs for an Author query 

These are user-defined Stats codes. Set 

also in Main > Supervisor > WebParams 

screen. The Stats Parameters shown here 

are examples only and are the defaults set 

with the system. 

 

 

 

501 WebTitle Searches performed via the 

NetOpacs for a Title query 

502 WebSubject Searches performed via the 

NetOpacs for a Subject query 

503 WebKeyword Searches performed via the 

NetOpacs for an Any Keyword 

query 

507 WebNew New Item search conducted via the 

NetOpacs (Newitems.htm usage 

only) 

510 WebBorView Members have accessed their 

details via NetOpacs 

512 WebBorRenew Members have renewed an item 

via the NetOpacs 

513 WebReserve Items reserved via the NetOpacs 

531 Web Join Online Members joined via the NetOpacs 

532 Web Requests Requested items via the NetOpacs 

– for example: Order or ILL 

requests 

533 Web Change 

Details  

Members who have altered their 

details via the NetOpacs 

Adding a New Statistics Code 

Some codes can be created by users. For example: Stats Codes can be added to Reports (and Report 

Templates) to collect the number of times a report is run (RepCirculation and RepReservation reports 

can also have an additional Detail Stats Code to collect the number of notices generated during each 

run – for example: How many invoices sent in May).  

Corresponding entries have to be made in the Statistics Codes screen. 

These customised codes only refer to: 

DESCRIPTION CODES 

Opac Other  200s 

Reports 300s 

NetOpacs  500s 

1. Launch the Amlib client 

2. Go to Main > Supervisor > StatsParams – the Statistics Code screen will display 

3. Click the F1 New or F2 Insert button – a new line will appear in the table: 
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4. Type in a Stats Type code and a Stats Description – for example: 314 | 1st Email Odue 

5. Enter a Y in the Count (Y/N) column and a Y in any other column (field) by which you would 

like to be able to break down the statistics – for example: Locn (Y/N), Year (Y/N), Month 

(Y/N), Day (Y/N) 

6. Click the F3 Save button when complete 

In the example below, two (2) new Stats Types have been created:  

 314 | 1st Odue Email 

 315 | 1st Overdue Count 

These codes may now be added into a RepCirculation report (or report template) for statistics 

gathering purposes.  

 

Report Stats Codes 

It is possible to add a Stats Code to a Report (or Report Template) which can then be added to the 

Statistics Codes table. 
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Report Stats Code 

(RepAddNew: Default 

Stats Code) 

Keeps a count of the number of 

times this report is requested 

(for statistics) 

Assign a code of after 299 if required – 

for example: 350 

Detail Stats Code 

(RepAddNew: Default 

Detail Stats Code) 

Keeps a count of the number of 

items generated by the report 

How many items were subject to 

overdue reports. Assign a code of after 

299 if required – for example: 351 

To Add a Default Stats Code 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Report Files screen will display: 

 

3. From the Report Entity drop-down, select the a Reports module – for example: Circulation 

4. Either load a report template (using the F1 New button) or select an existing report and 

modify it (using the F2 Modify button) – the Circulation – New/Modify Report File screen will 

display: 

 

5. Enter a Default Stats Code – for example: 310 – this code is used to track the number of 

times the report is run (this can match an existing code in the Statistics Codes table or can be 

defined here and added to the Statistics Codes table afterwards)  
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6. If the file is a Circulation or Reservation template, then enter a (different) Default Detail Stats 

Code  – for example: 311  - this code is used to track the number of notices generated when 

the report is run (this can match an existing code in the Statistics Codes table or can be 

defined here and added to the Statistics Codes table afterwards) 

7. Click the F3 Update button when complete 

To Add a Stats Code to a Report 

1. Launch the Amlib client 

2. Select a Reports module – for example: Main > Reports > RepCirculation – the Circulation 

Reports screen will display:  

 

3. Select a report in the list to which you would like to add a Report Stats Code – for example: 

Email Overdue 

4. Enter a Report Stats Code – for example: 314 – this code is used to track the number of times 

the report is run (this can match an existing code in the Statistics Codes table or can be 

defined here and added to the Statistics Codes table afterwards)  

5. If the file is a Circulation or Reservation template, then enter a (different) Default Detail Stats 

Code  – for example: 315  - this code is used to track the number of notices generated when 

the report is run (this can match an existing code in the Statistics Codes table or can be 

defined here and added to the Statistics Codes table afterwards) 

6. Click the F3 Update button when complete 

Please Note:  You may like to use different sets of codes to differentiate between different report 

templates or even different reports using the same template – this will allow you the opportunity to 

create highly specific statistics sets. 

Web Stats Codes 

1. Launch the Amlib client 

2. Go to Main > Supervisor > WebParams – the Web Opac Parameters screen will display: 
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3. From the main menu, select Html Parameters > Open... 

 

4. An .ini file will be visible, select it and click on the Open button 

5. The NetOpacs Setup screen will display: 
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6. Highlight on the Template you would like to check: in this case Keyword Search 

7. Click the Setup button – the Screen Types screen will display: 

 

8. Select the Screen Type, in this case: Keyword Search and click on the OK button 

9. The Keyword Search screen will display 
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10. You will be able to check Enq. Statistics Code: 

 

11. Alter Enq. Statistics Code as appropriate 

12. Click the OK button when complete – the Keyword Search screen will close 

13. Click the OK button on the NetOpacs Setup screen – you will get a message informing you 
that you can now recompile the NetOpacs 

When changes are made to the NetOpac pages or the NetOpac amlib.ini file, then it is necessary to 
recompile the pages and restart the service manager for these changes to fully take effect. 
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STATISTICS REPORTS 

The creation of a report is covered in broad terms by the following flowchart: 

 

 

 

 

 

 

 

 

 

 

  

Template 
Design and Function 

Create Report 
Report selection and description 

Data 

Search conditions and parameters 

Files with .QRP 

extension 

Created/edited 

 in Report Writer 

(REPWIN30.EXE) 

Determined by Where 

parameters or by 

selecting a Saved File 

Report Type 
Matching template to module and function 

Order 

Sequencing the results  

Results 

View/printing results  
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RepStatistics (Statistics Reports) 

 Go to Main > Reports > RepStatistics 

o If Report Stats Codes set – Statistics table updated 

Most template names begin with &STAT and are all similar but reflect different sequencing of data. 

The report names will give an indication of the order in which parameters should be selected: 

TEMPLATE CODES 

 &STAT1 – summaries by Year, Form 

 &STAT2 – summaries by Year, Month 

 &STAT3 – summaries by Year, Month, Day 

 &STAT4 – summaries by Year, Month, Day, Hour 

 &STAT5 –  details by Borrower Type 

 &STAT6 – count by Location, Type, Borrower 

 &STAC – Location, Borrower Class, Form 

 &STAG – Location, Borrower Group, Form 

Some Statistic Reports have the Order predefined. If using a Statistic Report that has not been 

updated, the letters in the Description indicates the content and how the order is to be defined.  

LETTER DESCRIPTION 

l location 

t type (Statistical Type) 

b borrower 

f form 

s stats code 

y year 

m month 

d day 

h hour 
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Order 

The updated reports have their Order predefined and cannot be changed. If using a Report where 
the Order is not predefined, set the Order in the order the description displays – for example:  ltfb 
will be ordered by Location (l), Trans Type (t), Item Form (f) and Borrower Type (b).  

If you do not set the order correctly you will get an incorrect result in the report which could result in 
forests of paper being printed! 

Special Button 

Useful for Dates as options include Current Date, Start of Week, Start of Month. 

 

Heading for the Report 

On many Templates the Heading is taken from the Report Description as written. 

 

Ensure it is correct for the details of the Report. The actual data that displays comes from the Where 

parameters and not the Report Description. This Report Description will be important as it is an 

indication of what the report will show so that you will know for next time, and that it also forms part 

of the heading for the Report (dependent on the Template of the Report). 
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HINT: When it comes to changing the Where parameters for the Month, Year etc. ensure that you 

also change the Report Description and Save before Viewing to ensure the Heading is also correct! 

Setting Time Periods 

Setting Time Periods is very flexible and uses the Where parameters to get the time period required. 

For example: 

Calendar Year Trans Year = 2010 

Several Years Trans Year IN 2009,2010,2011 

Financial Year  Trans Date ≥ 01/07/2009 and Trans Date ≤ 30/06/2011 

Quarter – for example: 1st Qtr 2011 Trans Year = 2011 and Trans Month IN 01,02,03 

Month – for example: March 2011 Trans Year = 2011 and Trans Month = 03 

Term – for example: Term 1, 2011 Trans Date ≥ 01/02/2011 and Trans Date ≤ 17/04/2011 

Semester – for example: Sem 1, 2011 Trans Date ≥ 01/02/2011 and Trans Date ≤ 03/07/2011 

Week Trans Date ≥ Start of Week (via Special Button) ≤ Current 

Date (via Special button)  

or Trans Date ≥ 08/09/2010 and Trans Date ≤ 13/09/2010 

Day Trans Date = Current Date (via Special button), or Trans 

Weekday = 3 (Sun 0, Mon 1, Tue 2, Wed 3, Thur 4, Fri 5, Sat 

6), 10/09/06 for a specific date, or Trans Day = 10 (for 10th) 

Hour  Trans Year = 2011 and Trans Month = 03 and Trans Day = 

10 and Trans Hour > 15 (for 3pm) 
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STATISTIC REPORTS - SAMPLES 

Summary Statistics (Predefined Order) 

In the Where parameters the Trans Type can be defined so as to only get the summary of the Trans 

type/s to be reported, or left undefined so that the report will give a summary of ALL statistics kept 

by Amlib (as in the following example): 

 

Location, Trans Type, Trans Year:  &STAT100.QRP 
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Location, Trans Type, Trans Year, Trans Month &STAT200.QRP 

 

Location, Trans Type, Trans Weekday, Trans Hour &STAT4I.QRP 

This report can be set to show what was loaned out for a single week, patterns over a month, a 

quarter etc. depending on what is set in the Where Parameters. 
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Location, Trans Type, Trans Weekday (week matrix) &STAT4J.QRP 

 

Detailed Statistics (Predefined Order) 

In the Where parameters the Trans Type is usually defined to ensure that only the details of certain  

Trans Type/s are to be reported – otherwise the report will be huge and largely irrelevant! For 

example the details required in the report below are only for Issues, Renewals, New and Deleted 

Borrowers. 
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Details by Location, Trans Type, Borrower Type - &STAT600.QRP 
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Details by Location, Trans Type, Item Form Type, Borrower Type - &STAT500.QRP 
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Details by Location, Trans Type, Borrower Type, Item Stats Collection Code - &STAT520.QRP 

 

Details by Location, TransType, ItemForm, Item Stats Collection Code - &STAT560.QRP 
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Please Note: If the totals are showing accumulative totals, contact Amlib Support for an updated 

template. 

Details by Location, Trans Type, Item Form Type - &STAT640.QRP 
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Details by Location, TransType, Item Stats Collection Code - &STAT620.QRP 

 

Daily Statistics 

Use the current date in the Special button with the chosen report template – for example: Summary 

by Weekday, Hour - &STAT4I.QRP. This will display the activity, showing hours and totals for the 

current day. 
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Daily Statistics for the Week 

HINT: Use the Special button to get Start of Week or Current Date (Start of Week = Sunday of each 

week) 

 

 

Monthly Statistics 

Gathering monthly statistics take a large amount of system resources so are best done when the 

library is not busy. You are able to modify the same report that you used last month. 

1. Launch the Amlib client 

2. Go to Main > Reports > RepStatistics – the Statistics Reports screen will display 

3. Select the report required (or create a new report via the F1 New button) – for example: 

Summary lty or ltym(s) if wanting a breakdown of Monthly activities 

4. Change the Report Description to be accurate for this report – for example: Activity 

Summary (Sept 2010) 
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5. Click the F3 Save button when complete 

 

6. Highlight the report, and click the F7 Where button – the Statistics Reports – Where screen 

will display 

7. Delete the previous Trans Month condition by highlighting the line and clicking the Delete 

button 

8. Enter a new Trans Month condition: 

a. 1 – Choose Search Column: select Trans Month  

b. 2 – Choose Operator: select =  

c. 3 – Type the WHERE Condition: enter the relevant month in two digit format – for 

example: 09 (for September).  

d. Click the Paste button 

 

9. If the Year or Month needs changing, delete the Trans Year or Trans Month condition from 

the existing Report and enter a new condition – for example: Trans Year = 2011 or Trans 

Date = 10 

10. Click the F3 Save button when complete 
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11. Click the F8 View button to preview the report – the report will display in the Report – View 

screen 

12. Click on the print icon to print the report – the report may take some time to print, 

depending on system resources and the size of the statistics, etc 

Statistics between a Range of Dates 

 For example: Quarterly, Term, Semester Dates 

Can be collected as above but use the Trans Date in dd/mm/yyyy format to enter the date range to 

begin (using > or ≥) and the date to end (using < or ≤) 
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EXCEL REPORTS 

A number of report templates have been designed to save statistical and count data in .txt format 

and is semi-comma delimited. The output from the report templates can be saved as a .txt file by 

using the Reports Scheduler. Once opened in MS Excel, the data can be customised using the 

formatting the tools of Ms Excel. 

Listed below are the CSV reports based on existing Amlib Report Templates: 

Statistics Reports 

 Reports Module: RepStatistics 

Yearly Basis 

 &XSTAT10.QRP – Summary by Location, Trans Type, Trans Year 
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Monthly Basis 

 &XSTAT20.QRP - Summary by Location, Trans Type Trans Year, Trans Moth 

 

Daily Basis 

 &XSTAT30.QRP  Summary by Location, Trans Type, Trans Year, Trans Month, Trans Day 
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Detail Summary 

 &XSTAT50.QRP – Details by Location, Trans Type, Borrower Type, Item Form Type   

 

 &XSTAT52.QRP – Details by Location, Trans Type and Stats Code 

 

 &XSTAT53.QRP – Details by Location, Trans Type & Form Code 
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Borrower Count Reports 

 Reports Module: RepBorrower 

 &XBCT.QRP – Counts by Borrower Type 

 

 &XBCLT.QRP – Counts by Location & Borrower Type 
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Stockitem Counts Reports 

 Reports Module: RepStockitem 

 &XSTKCS.QRP – Stockitem Count by Stats Code 

 

 &XSTKCLS.QRP – Stockitem Count by Location & Stats Code 

 

 &XSTKFS.QRP – Stockitem Count by Form Code 

 

 &XSTKCSV.QRP – Stockitem List: Title, Author, Call No, Form Code, Stats Code, Location, 

Floor, Cost in CSV format (delimited by '|') 
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SAVING A REPORT TO FILE (FOR IMPORT INTO EXCEL) 

You can save your reports to a file, for email or formatting, or just to keep it in an electronic format 

rather than paper. The two ways of doing this are by Table or Report. 

Table 

1. Access a module and perform a search – the results will display in a List 

2. Highlight the items you would like to save to file 

3. Type Ctrl-C to copy them 

4. Open up MS Excel or Word 

5. Type Ctrl-P to paste the selection into a table or page 

After getting a table of results in one of the modules, you can highlight them all to select them and 

do Ctrl + Insert to copy them. Then you can paste the items into Excel or Word. 

 

↓ 

 

This method works best if you don’t have a large number of results. 

  



Statistics Training 

 

 

Last Updated: 26 February 2013 
 Page 57 

Report 

There are several Excel report templates available which can be used to save to a file. In this 

example, we are going to use the &XSTKCSV.QRP template in the Reports > RepStockitem module: 

1. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will open 

2. Click the F1 New button and select the &XSTKCSV.QRP template 

3. Type in an appropriate Description and click the F3 Save button 

4. Enter an appropriate F7 Where search – for example: Title LIKE Harry Potter 

5. Order the Report – for example: Title | ASC 

6. Select Application > RepStartSchedule – ensure that Save to File is ticked and click on the OK 

button 

 

7. Click the F6 Print button – change the To: option to File and click the OK button 

 

8. A Report – Save As dialogue box will open: 
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a. To save it for a Word document, leave the Save as type: as Rich Text Format (RTF) 

b. To be able to open it in Excel, change the Save as type: to Text Document 

 

9. You can check the progress of your report in Reports > RepPrintProgress 

10. If you’ve saved the report to open in Excel (Text Document) then you will need to follow 

these steps so it is displayed correctly: 

a. Open Microsoft Excel 

b. Use File > Open to open the text file you’ve saved – ensure that the Files of type: = 

All Files (*.*) 

c. The Text Import Wizard will open 
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d. Excel will recognise your file as Delimited, so click the Next button 

e. Delimiters: select Semicolon and add a pipe | in the Other box 

f. Click the Next button and then the Finish button 

 

11. Your data will be transferred into the Excel sheet and you can now use the formatting tools 

to customise it: 
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SYSTEM AUDITS & AUDIT REPORTS 

The audit reports list stockitems/authorities/borrowers that have been deleted, inserted (added) or 

updated (modified/changed) within a specified time period. 

In addition to the audits, there are a number of Statistics Reports Audits that look at Operator logons 

and alterations, as well as searches performed in each module. 

Supervisor Settings: Setting Up Audits 

The Audit must be switched on first, before the data can be collected. To check this: 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation > Other tab 

3. There are several types of audit: 

 Create an audit for all Authorities (Y/N) 

 Create an audit for all Borrowers (Y/N) 

 Create an audit for all issues prompted with messages (Y/N) 

 Create an audit for all Stockitems (Y/N) 

4. If you would like to keep audit details, ensure that these are set to Y (particularly the last) 

5. Make sure you also check your settings by individual Location: 

a. Select Installation > Choose Location 

b. Select location and click on the OK button 

c. Select the Other tab 

Please Note: Any record/s that were deleted, inserted or updated prior to the audit being switched 

on will not be recorded. 
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Issues Audit 

Issues Audit records all messages that are displayed in issues. If you do not use this particular 

function, make sure the audit is switched off (see Supervisor Settings above): 

 Create an audit for all issues prompted with messages (Y/N) = N 

As the logs fill up quickly and must be regularly maintained (old entries deleted daily or weekly). 

To access the Issues Audit: 

1. Open the Supervisor module 

2. Select LibraryMenu > IssuesAudit – the Issue Audit table will display 

3. Select the F6 Print button to print up the list 

 

To delete entries from the table: 

1. Open the Supervisor module 

2. Select LibraryMenu > IssuesAudit – the Issue Audit screen will display 

3. Highlight the entries in the list to be deleted 

4. Click the F4 Delete button – this will mark the entries for deletion 

5. Click the F3 Update button to delete the marked entries 
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Load the Template 

Some audit report templates may need to be loaded before they can then be used in a report.  You 

can also use this method to double-check the Choose Type of an already loaded template. 

1. Go to Main > Reports > RepAddNew – the Report Files window will open 

2. Select the appropriate Report Entity: either Authority, Borrower, Statistics or Stockitem – in 

the example below: Report Entity = Stockitem 

3. Click the F1 New button – the New Report File pane will open 

4. Type in a Description – for example: Audit Full Details 

5. Click on the Browse button to view the Amlib/Reports folder on your Amlib server and 

locate the template to be loaded – be sure to change the Files of type: drop-down to System 

Report Templates (*.qrp) 

6. Select the template to be loaded and click on the Open button 

7. Change the Choose Type to select an Audit type: 

 Authority: Authority Audits 

 Borrower: Audit Report 

 Stockitem: Item Audit 

 Statistics: Access Audit, Logon Audit or Search Audit 

8. You can leave Default Stats Code blank 

9. Update Entity (Y/N) = N 

10. Click on the F3 Update button 

11. Close out of the Report Files screen 

The template is now loaded and available for use in a Report. 
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Authority Audit Reports 

 Reports can be set up in Main > Reports > RepAuthority 

There is only one type of audit report available: 

 Audit report: &AUTHAUD.QRP 

1. Go to Main > Reports > RepAuthority – the Authority Reports screen will display 

2. Click the F1 New button 

3. Select the &AUTHAUD.QRP template 

 

4. Type a Report Description – for example: Audit New Authorities 

5. Click the F3 Save button 

 

6. Highlight the Audit report and click the F7 Where button – the Authority Reports – Where 

pane will display 

7. Enter your Where parameters – there are three audit types:  
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 D: Deleted 

 I: Inserted 

 U: Updated 

The Where parameters will depend on what you are after.  Typically you would set the Date 

and Audit Type (I/U/D).  You may also include tag numbers or span of numbers (for example: 

> 600 AND < 700). 

 

8. Click the F3 Save button when complete 

9.  (Optional) Click the F9 Order button – you can then set the order for the report to print in. 

You can sort by Date and Tag (or vice versa if you’re looking for a particular tag).  Click the F3 

Save button when complete. 

 

10. Click the F8 View button to view the report 

11. Select the print icon to print the report 
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Borrower Audit Reports 

 Reports can be set up in Main > Reports > RepBorrower 

There is only one type of audit report available: 

 Audit: &BORRAUD.QRP 

1. Go to Main > Reports > RepBorrower – the Borrower Reports screen will display 

2. Click the F1 New button 

3. Select the &BORRAUD.QRP template 

 

4. Type a Report Description – for example: Borrower Audit 

5. Click the F3 Save button 
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6. Highlight the Audit report and click the F7 Where button – the Borrower Reports – Where 

screen will display 

7. Enter your Where parameters – there are three audit types:  

 D: Deleted 

 I: Inserted 

 U: Updated 

The Where parameters will depend on what you are after.  Typically you would set the Audit 

Date and Audit Type (I/U/D). You may also want to limit by Location, Borrower Type, etc. 

 

8. Click the F3 Save button when complete 

9. (Optional) Click the F9 Order button – you can then set the order for the report to print in. 

You can sort by Audit Date and Barcode (or vice versa if you’re looking for a particular 

patron).  Click the F3 Save button when complete. 
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10. Click the F8 View button to view the report 

11. Select the print icon to print the report 
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Statistics Audit Reports 

 Reports can be set up in Main > Reports > RepStatistics 

There are three types of audit reports available: 

 Access Audit: &SAAUDIT.QRP 

This report displays access to the Authorities and Catalogue modules by Operator showing 

alterations made. 

 

 Logon Audit: &SLAUDIT.QRP 

This report displays the date and time Operators logged onto the Authorities and Catalogue modules. 

 

 Search Audit: &SAUDIT.QRP 

This report displays Search terms used with the Authorities and Catalogue modules and the type of 

search done. 
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Creating a Statistics Audit Report 

1. Go to Main > Reports > RepStatistics – the Statistics Reports screen will display 

2. Click the F1 New button 

3.  Select an audit template (Access, Logon or Search) 

 

4. Type a Report Description – for example: Logons Used 2010 

5. Click the F3 Save button 

 

6. Highlight the Audit report and click F7 Where – the Statistics Reports – Where screen will 

display 

7. Enter your Where parameters – there are two module types:  

 AUTHORITY 

 CATALOGUE 
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The Where parameters will depend on what you are after.  Typically you would set the Date 

and Module parameters, and perhaps Location (Operator Logon Location). 

 

8. Click the F3 Save button when complete 

9. (Optional) Click the F9 Order button – you can then set the order for the report to print in. 

You can sort by Operator and Module (or vice versa if you’re looking for a particular item).  

Click the F3 Save button when complete. 

 

10. Click the F8 View button to view the report 

11. Select the print icon to print the report 
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Stockitem Audit Reports 

 Reports can be set up in Main > Reports > RepStockitem 

There are three types of audit reports available: 

 Audit Brief Details: &SADBR.QRP 

This report displays a small amount of information for each item. 

 

 Audit Medium Details: &SADDET.QRP 

This report includes some additional fields: location, publisher, form and stats codes. 
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 Audit Full Details: &STKAUD.QRP 

This report displays many additional fields for each item. 

 

Creating a Stockitem Audit Report 

1. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display 

2. Click the F1 New button 

3.  Select an audit template (brief, medium or full details) 

 

4. Type a Report Description – for example: Audit 2010 

5. Click the F3 Save button 
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6. Highlight the Audit report and click the F7 Where button – the Stockitem Reports – Where 

screen will display 

7. Enter your Where parameters – there are three audit types:  

 D: Deleted 

 I: Inserted 

 U: Updated 

The Where parameters will depend on what you are after.  Typically you would set the Audit 

Date and Audit Type (I/U/D) parameters, and perhaps PermLoc (Permanent Location). 

 

8. Select the F3 Save button when complete 

9.  (Optional) Click the F9 Order button – you can then set the order for the report to print in. 

You can sort by Audit Date and Title (or vice versa if you’re looking for a particular item).  

Click the F3 Save button when complete. 
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10. Click F8 View to view the report 

11. Select the print icon to print the report 
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SPREADSHEET PARAMETERS 

It is possible to define any number of spreadsheets within the system. You may then choose to 

export data and titles to other spreadsheets and continue manipulation in a spreadsheet package 

(for example MS Excel). It may be preferable to set up a spreadsheet first in the chosen Spreadsheet 

software, knowing the statistics to be collected. The headings and layout can be created, using the 

Amlib Spreadsheet purely to collect the data and transfer it into the chosen spreadsheet template. 

You will need to identify which rows the data will be transferred to within the chosen spreadsheet so 

that you can accurately enter the Data on the correct row in the Amlib spreadsheet. 

Spreadsheets take some time to set up, but once defined they can be copied and manipulated for 

other spreadsheets you wish to define. 

Presenting data graphically, especially if you have access to a colour printer can be a powerful tool in 

presenting statistics. 

To actually transfer data using a stored spreadsheet the System Activity Window in Supervisor is 

used. 

The Spreadsheet within Amlib is made up of Heading lines and Data lines. 

Example: 

                            1                2         3      4        5         6       7       8        9      10       11     12      13     14 

1  Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec Total 

2 New 

Borrowers 

             

3 Issues              

4 Returns              

5 Renews              

6 Reservations              

7               

8               

Format 

 The first (1st) column contains the spreadsheet name.  

 The second (2nd) column contains the sequence number for the Amlib system. This is not very 

important and only affects the order in which the data is presented in this maintenance 

table. It can be useful when setting up the Spreadsheet to keep datalines together (For 

example, Stats code of AF could be kept together, number from 10 to 19, ANF 20 to 29 etc.) 

 The third (3rd) and fourth (4th) columns relate to the columns and rows in the actual 

spreadsheet itself and should be unique as a combination within this table. 
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 The 5th column indicates whether the information in the particular row is a Heading or Data.  

Headings 

Headings are indicated by an ‘H’ in the 5th column.  

Please Note: You do not need to enter any heading lines. If you prefer, you can keep these in the 

actual spreadsheet file to which you will then only transfer data. 

 Column six contains the heading text 

 

Data Lines 

 Datalines are indicated by an ‘D’ in the 5th column 

The important element is the text entered in the columns following the 5th column. This will 

determine the data that is transferred from the database into the spreadsheet. Where a column has 

some data then only that data is included. For example, to include data transactions for a certain 

year, the year is entered in the 6th column. 

Where no data is specified then all possibilities under that column will be included. i.e. if we leave 

the date blank we will get all possible years (accumulated into this column). 

All numeric data can be entered as is. All alpha data needs to be entered with inverted commas. For 

example ‘LIB’. 

Columns exist for the following: 

DATA COLUMNS DESCRIPTION EXAMPLE 
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Year Four digit format 1999 

Month Numbered as to each month of the 

year 01 - 12 

01 for January 

Day Numbered as to each day of the 

month  

23 for 23rd of January 

Hours Numbered as for a twenty four clock 8 – 16 for 8am – 4pm 

From this date To determine beginning date range 

(dd/mm/yy) 

12/04/99 for 12th April 

1999 

To this date To determine ending date range 

(dd/mm/yy) 

04/10/99 for 4th October 

1999 

Current date minus n 

days 

Specific date. 7 would indicate data 

from a week ago. 

Transactions Codes that derive from the Stats 

Parameters in Supervisor. 

05,06 indicate issues 

(05) and renewals (06). 

Locations If getting data for one branch enter 

the branch code from the Location 

table in Supervisor. 

‘ELD’ for Eldorado 

Branch, or 01 if numeric. 

Stock Codes From the table Stockitem, 

Application, Item Stats. 

‘AF’ for Adult Fiction. 

Form Codes From the table Stockitem, 

Application, Item Forms 

‘BK’ for Book 

Borrower Types From the table Borrower, 

Application. 

‘A’ for Adult, ‘Y07’ for 

Year 7 etc. 

Borrower Groups From the table Borrower, 

Application. 

‘E’ for Endeavour etc. 

Borrower Class From the table Borrower, 

Application. 

‘R8’ for Room 8 etc. 

Suburbs From the table Borrower, 

Application. 

‘MAN’ for Manning 

Wards From the table Borrower, 

Application. 

‘C’ for Civic 

Areas From the table Borrower, 

Application. 

‘NE’ for North East 

Metropolitan etc. 

 

If you have several codes in the same field, the data that will be transferred will be the combined 

value. Therefore, if you want separate values, these must be on different lines. For example, if you 

want figures for two different locations, each location would need to be given a separate data line.  
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Each data line gets one total from the database. We could have a data line totaling each of the 

columns 5,6, 8 and 9 and have this passed through to the spreadsheet but it would more efficient to 

have the spreadsheet calculate this itself. 
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SYSTEM ACTIVITY 

The system activity window gives a brief overview of the system for the following activities. The 

colours used in the graph are different for each activity. 

 Issues (Green) 

 Returns (Red) 

 Reserves (Blue) 

 Enquiry (Yellow) 

This window may also be used to initiate spreadsheet data transfer. 

1. Launch the Amlib client 

2. Go to Main > Supervisor > System Activity – the Circulation Activity screen will display: 

 

3. This window is actually using the collected statistics and may be used to view any period by 

changing the from and to values for Hrs, Days, Mths and Yrs fields from the top of the 

window (highlight the field with your mouse and overwrite it) and then selecting Window > 

Refresh from the menu – the following ranges apply: 

a. Hrs: 0 – 23 – for example: 8 – 18 (for stats between 8am and 6 pm) 

b. Days: 1 – 31 – for example: 1 – 12 (for the first 12 days of the month) 

c. Mths: 1 – 12 – for example: 1 – 3 (for the first quarter) 

d. Yrs: 2XXX – 2XXXX – for example: 2009 – 2010 (for the 2009 and 210 stats) 

Please Note: By default, the Hrs, Days, Mth and Yrs fields will default to the current date and time. 

Please Note: When viewing statistics on the system activity window you may only view down to the 

level at which stats are being collected – for example: if you are not collecting by hour enter 0 - 23 in 

the hours fields. 
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4. The display can be changed to be Hour, Day, Month or Year using the Summarised by radio 

button selections at the bottom of the screen 

5. The default display is: All Locations – to view a particular location in isolation: 

e. Select Window > ChooseLocation from the menu 

 

f. The following prompt will display: 

 

g. Highlight the desired location and click the OK button – the Location at the top of 

the screen will change to match the selected Location 

These fields can be adjusted and 

then Window > Refresh selected 

to populate the display 
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h. Select Window > Refresh to refresh the statistics displayed 

 

6. The default display is to show IssuesReturns – the system activity can be changed to be 

viewed by Borrower (Green), Stockitem (Red), Catalogue (Blue) and Authority (Yellow) by 

selecting Window > Enquiries and then Window > Refresh 

 

As the population of statistics grows the data collection queries may take some time so this should 

not be activated when the system is busy. 

Please Note:  Use Window > Refresh whenever you have changed any of the selection fields. 

Printing 

If you have a colour printer, you can print the image. There is no Print button in the Amlib client but 

you can capture a screenshot by holding the Alt button while clicking the PrtScn button on your 

keyboard. You can then paste (Ctrl + V) the image into Word or WordPad for printing. 
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Spreadsheet Facility 

The System Activity window may also be used to initiate spreadsheet data transfer. 

1. Launch the Amlib client 

2. Go Main > Supervisor > System Activity – the Circulation Activity window will display 

3. Set the statistics you would like to export to Excel (see above) 

At this point you have the option of creating a new Spreadsheet (Load Spreadsheet) or opening one 

already created (Open Spreadsheet). 

Load Spreadsheet 

This option will load the spreadsheet software from the area defined in the Installation window 

(Main > Supervisor > Installation > Other tab – Path of spreadsheet). 

 

1. From the menu, select Window > LoadSpreadSheet – the Spreadsheet program should open 

(in this example: MS Excel) 

Open Spreadsheet 

Allows you to open an existing spreadsheet file. You are able to transfer data to an existing 

spreadsheet. 

1. From the menu, select Window > OpenSpreadSheet – the Circulation Activity – Open 

window will display 

2. Locate the existing spreadsheet and click on the Open button 
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Select Sheet Formula (Optional) 

It is possible to use one of the Spreadsheets previously defined in the Spread sheet definitions  table 

(Main > Supervisor > Supervisor, LibraryMenu > SpreadSheetParams) 

1. From the menu, select Window > SelectSheetFormula – the Select Spreadsheet table will 

display with a list of pre-defined spreadsheet parameters: 

 

2. Select the desired set of parameters and click the OK button 

Transfer Data 

1. The Transfer Data option will now be available (from the menu, select Window > Transfer 

Data) 

2. The data will be transferred to the open spreadsheet 

3. You may then leave Amlib to go and work on the spreadsheet if desired, this could look like 

the following, including the ability to graph results if required: 
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4. Select Save As... within the spreadsheet program and save the file when complete 

Please Note: If you want to transfer more data to another spreadsheet then use the Window > 

StopSpreadSheet option to disconnect from the first spreadsheet. 

 


