
 
 
 
 
 
 
 
 
 

Basics: 
Manage Local Files 

Last revised: May 2021 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

6565 Kilgour Place, Dublin, OH 43017-3395 
www.oclc.org 

OCLC Connexion Client Guides 

http://www.oclc.org/


Page 2 of 15 

Revision History 

Date Section title Description of changes 
May 2014 1 Manage local files Removed information about expiration of saved records. 
September 2012 All Removed references to Pathfinder. 
July 2007 1 Manage local files Added a procedure for restoring records from a client backup 

(*.bac) file. These files are produced when the Auto Back Up 
option available from File > Local File Manager is set to Back 
up... (default setting: Back up to same folder as original file). 

May 2021 1 Manage local files Added a note pointing to Connexion client version 3.0 
documentation. 

© 2014 OCLC Online Computer Library Center, Inc. 
6565 Kilgour Place 
Dublin, OH 43017-3395 USA 

OCLC® users are hereby granted permission to reproduce this manual for their internal use. Reproduction of substantial portions of 
this manual must contain the OCLC copyright notice. 

The following OCLC product, service and business names are trademarks or service marks of OCLC, Inc.: CatExpress, Connexion, 
DDC, Dewey, Dewey Decimal Classification, OCLC, WorldCat, WorldCat Resource Sharing and “The World’s libraries. Connected.” 
In addition, the WorldCat symbol and OCLC symbol are service marks of OCLC. Third-party product and service names are trade- 
marks or service marks of their respective owners. 



Page 3 of 15  

Table of Contents 
1 Manage local files for offline cataloging 

About local files, 4 
Offline/online cataloging using local files, 5 
Add locations and/or create local files, 6 
Delete a local file, 7 
Select a default local file, 7 
Default authorization for batch processing using local save file (required), 7 
Define a holding library code and institution symbol or MARC organization code 

for offline cataloging, 8 
Define a classification scheme, 9 
View batch processing reports, 10 
View statistics for a local file, 10 
Copy or move local file record(s), 12 
Export records from local file, 12 
Back up local files automatically, 13 
Restore data from a client backup file, 14 
Compact/repair a local file, 14 



Basics: Manage Local Files 

Page 4 of 15 

1 Manage local files for offline cataloging 

Note: If you are using Connexion client version 3.0 or newer, see Connexion client for applicable documentation. 

About local files  What are local files?
— Connexion client local files are located on your workstation or can be located 

on a network drive for shared access. 

Note: More than one person can use a shared file at the same time, but only 
one user at a time can open a record in a local file. 

— Use local files to save bibliographic and authority records, to create and store 
bibliographic and authority constant data, to set actions on records or enter 
WorldCat or Library of Congress (LC) authority file searches for batch 
processing. 

 Types of local files, default names, and locations.
The client supports four types of local files. When you install the program, the
setup program creates a default local file for each type, ready for you to add
records:
— Bibliographic save file: DefaultBib.bib.db
— Bibliographic constant data file: DefaultBibCD.bibcd.db
— Authority save file: DefaultAuth.auth.db
— Authority constant data file: DefaultAuthCD.authcd.db

The default location for local files is:
— X:\Documents and Settings\[user name]\Application

Data\OCLC\Connex\Db, where X is the letter of your hard drive 

 Multiple files.
Create additional separate files of any type for specific cataloging activities or
for individual staff members.

 Record limit.
Each local file can store up to 9,999 records.

 Adding records.
Records you save in a local file are appended to existing records in the file.

 Local file manager. The client provides a local file manager (File menu) to
allow you to:
— Define local file paths
— Create multiple local files
— Delete local files
— Set a local file as the default
— Assign a separate authorization and password to a local save file
— View the number of records in a selected local file by status(es).
— Set options for automatically backing up local files.
— View batch processing reports

https://help.oclc.org/Metadata_Services/Connexion/Connexion_client
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 Cataloging settings. 
In the Local File Manager, establish a separate authorization/password for a 
local file for both interactive logon and batch processing logon. (See procedure 
below.) 

 
In addition, in the Tools > Options > General tab, select cataloging options for 
local files that are different from those in the cataloging profile associated with 
your logon authorization. Define: 
— Holding library code and institution symbol or (for NACO-authorized libraries) 

MARC organization code 
— Classification scheme 

 
Notes: 

 

 
 
 
 

Offline/online 
cataloging using local 
files 

 OCLC recommends keeping the default setting to back up local files 
automatically to protect your data. If a local file becomes unusable, you can 
rename the backup file to make it the current file. 

 
 Save records to the local bibliographic or authority save file when you: 

— Search WorldCat or the LC authority file interactively or via batch searching 
— Search the online bibliographic or authority save file 
— Import records 
— Create records 
— Move or copy records from other local files 

 Save bibliographic or authority constant data to local files when you: 
— Create constant data 
— Search the online constant data file 

 Using a local file, work on records while: 
— Offline or online to: 

- Create records 
- Create constant data 
- Edit records and apply constant data or insert diacritics and special 

characters or text strings 
- Take immediate actions on single records or records selected in a list 
- Copy or move records from one save file to another 

— Offline only to: 
- Complete local processing: export records, print records, or print labels 
- Mark records with actions for batch processing 
- Enter batch search keys 

 
 Use local files to run batch processing 

 
For more information about batch processing, see: 
—”Enter WorldCat batch search keys” 
—“Enter LC authority file batch search keys” 
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Add locations and/or 
create local files 

—“Set actions on bibliographic records for batch processing” 
—“Set actions on authority records for batch processing” 
—“Run batch processing” 

You may want to: 

 Create multiple local files used for different purposes or by different library staff 
and locate distinct file categories on different drives or in separate folders 

 Place one or more local files on a network drive for sharing by several staff 
members 

 
To add a new location for local files: 

 
 Action 

1 On the File menu, click Local File Manager, or press <Alt><F><F>. 

2 Click Configure Paths. 

3 In the Configure Local File Paths window, click Add. 

4 In the Browse for Folder window, navigate to the folder you want to designate as 
a location, or navigate to a location and create a new folder by clicking New Folder 
and typing a name. 

5 Click OK or press <Enter> to add the new location, or click Cancel. 
 
Result:The full path name of the new location appears in the Configure Local Paths 
window. Click OK to close the window. 

To create a new local file and, optionally, a new location: 
 

 Action 

1 In the Local File Manager window (File > Local File Manager), under Choose File 
Type, click the type of file you want to create. Select one of the following: 
 Bibliographic 
 Authority 
 Bibliographic Constant Data 
 Authority Constant Data 

2 Click Create File. 

3 In the Windows Open window, accept the default location (X:\Documents and 
Settings\[user name]\Application Data\OCLC\Connex\Db) and simply enter the new 
file name. Then click Open. 
Or 
Navigate to a different location, enter the name of the new file you want to create, 
and then click Open, and in the Add Path? message, click Yes to confirm or No to 
cancel. 

 
Tip: Do not type the file extensions *.bib.db, *.auth.db, *.bibcd.db, or *.authcd.db. 
The client supplies the file extension for you. 

 
Result: The path and file name you created appears in the Files list in the Local 
File Manager window. 
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Delete a local file 
 

 Action 

1 In the Local File Manager window (File menu), under Choose File Type, click the 
type of file you want to delete. 

2 In the Files list, click the file you want to delete, and then click Delete File. 

3 Click Yes to confirm or No to continue without deleting the file. 
 
Caution 1: Once deleted, you cannot recover the file. The client deletes it 
immediately and permanently. The file does not go to the Recycle Bin on your 
workstation. 

 
Caution 2: Do not delete a designated default local file outside of the client using 
Windows Explorer. 

 

Select a default local 
file 

 
 
 
 
 
 
 
 
 
 
 
 
 

Default authorization 
for batch processing 
using local save file 
(required) 

The client creates a default local file for each type supported when you install the 
program. To change the default: 

 
 Action 

1 In the Local File Manager window (File menu), under Choose File Type, click the 
type of local file for which you want to set a default. 

2 
In the Files list, the current default file is designated by a check mark (   ). Click 
the file you want to set as the default, and then click Set as Default. 

 
Result: The check mark now appears next to the file you selected. 

3 When finished, click Close. 

 Required. To run batch processing, you must define either: 
— A default general authorization in: 

Tools > Options > Authorizations 
Or 

— A default authorization specifically for a local file in: 
File > Local File Manager 

 If you enter an authorization/password for a local file: 
— The client overrides any general default authorization/password you set up in 

Tools > Options > Authorizations and uses the one you assigned to that 
local file. 

— The authorization/password for the local file is always listed first in the Logon 
OCLC window list (facilitates batch processing), whether or not you have the 
local file open. 

 If you do not enter an authorization/password for a local file, the client uses the 
default authorization/password you set in Tools > Options > Authorizations , 
when you log on or run batch processing using the file. 

 
Summary: It is optional to assign a default authorization to a local file, but if you 
do not, you must assign a general default authorization to be able to run batch 
processing. 
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To assign an authorization/password to a local file: 
 

 Action 

1 In the Local File Manager window (File menu), under Choose File Type, select 
Bibliographic or Authority (unavailable for local constant data files). 

2 In the Files list, click the name of the local save file to which you want to assign an 
authorization/password, and then click Authorization. 

3 In the Assign Authorization and Password window, enter an authorization and a 
password. 
Or 
Delete any authorization/password you entered for the file and leave the boxes 
empty if you want the client to use your default authorization and password in Tools 
> Options > Authorizations 

 
Default: Authorization and password are blank. The client uses your default 
authorization/password in Tools > Options > Authorizations for interactive or 
batch logon for the selected file. 

4 Click OK to assign the authorization/password to the file, or click Cancel to cancel 
assigning it. 

 
Results: 
 If assigned, the authorization/password is used for interactive logon and logon for 

batch processing for this local file. 
 For interactive logon, the assigned authorization/password is listed first in the 

Logon OCLC Connexion window list. 
 

Define a holding 
library code and 
institution symbol or 
MARC organization 
code for offline 
cataloging 

 Required. For offline cataloging, you must define a holding library code and 
institution symbol. 

 The client uses the holding library code and institution symbol you assign for 
bibliographic workforms, bibliographic constant data workforms, and imported 
records in a local file. 

 Required for NACO-authorized libraries. You must define a separate MARC 
organization code to use with authority workforms and imported records. 

 
To define required information for offline cataloging: 

 
 Action 

1 On the Tools menu, click Options, or press <Alt><T><O>, and then click the 
General tab. 

2 Click Offline Cataloging Options. 

3 In the Holding Library Code box, enter a code. 

In the Institution Symbol box, enter a symbol. 

In the MARC Organization Code box, enter a code (required for NACO 
participants only). 
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 Action 

4 Click OK or Cancel. 
5 In the General tab, click OK to save changes. 

Or 
Click Cancel (closes the Options window). 
Or 
Click Apply to save changes without closing the window. 

 

 
 
 

Define a classification 
scheme 

Note: These settings are only for offline cataloging. When you are logged on, the 
client gets this information from with your logon authorization and password. 

 
For offline cataloging, define a separate classification scheme to use with labels 
and to supply the blank call number field for bibliographic records and workforms 
in local bibliographic save file(s) (not used for constant data records and 
workforms). 

 
 Action 

1 On the Tools menu, click Options, or press <Alt><T><O>, and then click the 
General tab. 

2 Click Offline Cataloging Options. 

3 In the Classification Scheme list, select one of the following schemes: 
 Library of Congress (default) 
 Dewey 
 National Library of Medicine 
 Canadian 
 Government 
 National Agricultural Library 

4 Click OK or Cancel. 
5 In the General tab, click OK to save changes. 

Or 
Click Cancel (closes the Options window). 
Or 
Click Apply to save changes without closing the window. 

Note: When you are logged on, the client uses the classification scheme 
associated with your logon authorization and password. 
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View batch processing 
reports 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

View statistics for a 
local file 

From the local file manager, display batch processing reports for the most current 
batch runs: 

 
 Action 

1 In the Local File Manager window (File menu), under Batch Reports, click one of 
the 
following types of report you want to view: 
 Searches 
 Online Actions 
 Label Printing 
 Exports 
Notes: 
 Batch processing is available only for local save files (unavailable for local 

constant data. 
 Batch processing holdings by OCLC numbers (Batch > Holdings by OCLC 

Number) produces a batch report that is temporary. Once you close it, you 
cannot retrieve it. 

Result: Batch report(s) open behind the Local File Manager. If you select multiple 
reports, they open simultaneously behind each other. 

2 Click Close to close the Local File Manager window. 

3 
When finished with the batch reports, click  in the upper right corner of a report 
to close it. 

Note: Using the following procedure, you can only view statistics. You cannot 
retrieve the records. To view statuses and retrieve records, you must use 
Cataloging [or Authorities] > Show > By Local Save File Status. 

 
 Action 

1 In the Local File Manager window (File menu), under Choose File Type, select 
Bibliographic or Authority (unavailable for local constant data files). 

2 In the Files list, click the name of the local save file for which you want to see the 
number of records with specific statuses. 
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 Action 

3 Click Statistics. 
 
Results: 
The Status List for the specified file opens, showing for a local bibliographic file: 
 The number of records with Completed, Failed, or Ready status for the following 

actions: 
Delete Holdings 
Export 
Label 
Produce 
Replace 
Submit 
Update Holdings 
Validate 

 The number of records with the following source statuses: 
Derived 
Extracted 
Imported 
OCLC 
Workform 

 The number of records with the following workflow statuses: 
Completed 
In Process 
In Review 
New 

 The total number of records in the file 
Or showing for a local authority file: 
 The number of records with Completed, Failed, or Ready status for the following 

actions: 
Add 
Export 
Replace 
Submit 
Validate 

 The number of records with the following workflow statuses: 
Complete 
Imported 
In Process 
In Review 
New 

 The total number of records in the file 

4 Click OK to close the Status List window. 
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Copy or move local 
file record(s) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Export records from 
local file 

 
 When you export records (Action > Export) from a local file while offline, the 

client stores your billing information, sends it to the system the next time you 
log on, and displays a message summarizing the export information sent. 

 If you are logged on and change the default local file from either the local file 
manager (File > Local File Manager) or from the Search Bibliographic Local 
Save File window (Cataloging > Search > Local Save File), the client sends 
any export billing information from that file to the system and displays a 
message summarizing the export information sent. 

 Action 

1 With a local file record open or with records selected on a local file list, on the 
Action menu, click Copy Record or press <Alt><A><Y>. 
Or 
Click Move Record or press <Alt><A><V>. 
Copy places a second copy of the record(s) in the file you select and leaves the first 
in the original file. 
Move removes the record(s) from the original file and places it in the file you select. 
Notes: 
 Locked authority records: You cannot copy them. Only NACO-affiliated 

libraries can copy locked authority records. 
 Constant data records: 

— Local constant data records cannot be copied within the same file, since each 
record must have a unique name. To copy a record within the same file, use 
Edit > Derive > New Constant Data to create a copy with a different name. 

— Local bibliographic constant data records selected in a list can be copied or 
moved to another local file or to the online constant data file, but you cannot 
move multiple records selected in an online constant data list to a local file. 

2 Optional. Click Local File Manager to open the Local File Manager window if you 
want to create a new file. Then click Close to return to the Copy [or Move] Local File 
Record window. 

 
Result: If you created a new file, its path and file name are added to the list. 

3 In the Copy [or Move] Local File Record window, click the path and file name of the 
file to which you want to copy or move the record(s). 

4 Click OK to copy or move the records. 
Result: If the local file to which you copied or moved records already contains 
records, the copied or moved records are appended to existing records. 
Or 
Click Cancel to cancel the action and close the window. 
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Back up local files 
automatically 

By default, when you exit the client or change the default local file, the client backs 
up local files automatically in the same folder as the original file. 

 
The client initially provides the following default backup files for the default local 
files: 

 
 DefaultBib.bib.db.bac 

 DefaultBibCD.bibcd.db.bac 

 DefaultAuth.auth.db.bac 

 DefaultAuthCD.authcd.db.bac 
 

Recommendation: OCLC recommends keeping this default setting to protect 
your data in case a local file becomes unusable. You can restore data in a 
backed-up file by renaming it (see procedure below). 

 
To check or change the option or to select a different location for the backup file: 

 
 Action 

1 In the Local File Manager window (File menu), click Auto Back Up. 

2 In the Automatically Back Up Local Files window, click a button next to the option 
you want. Select one of the following: 

 
 Do not back up local files 

Not recommended. If this setting is necessary, please back files up manually. 
 
 Back up to same folder as original file (default) 

Automatically creates a backup file in the same folder using the same file name 
as the original, but with the additional file extension *.bac. 
Example: DefaultBib.bib.db.bac 

 
 Back up local files to [...] 

Select a different folder to store all backup files: Click Browse to navigate to the 
folder you want to use. 
— Once you select a location, the window displays the new full path name. 
— The client backs up all local files, no matter where they are located to the 

single folder you select. 
 

Caution: If your setting is for automatic backup to the same folder, and you 
create multiple local files of the same type located in different folders but with the 
same name, each time any one of the files is used as the default and backed up, 
existing data in the single backup file is overwritten, and you can lose backed-up 
data from one of the other files. 

3 When finished, click OK to save your setting, or click Cancel to restore the former 
setting. 
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Restore data from a 
client backup file 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Compact/repair a local 
file 

To restore data from a backup file the client has automatically saved (you must 
have the automatic backup option selected, as described above): 

 
 Action 

1 Exit the Connexion client. 

2 In Windows Explorer, navigate to the folder that contains the *.bac file of records 
you want to restore. 

3 Single-click the file and then single-click again to select the file name for editing. 
Rename the file using a unique name and ending with the file extension *.db. 

 
Example: Change file name DefaultBib.bib.db.bac to RestoredBib.bib.db. 

4 If you selected the option to back up all local files in one folder rather than 
backing up each one in the same folder with the original file (see procedure 
above for backing up files): 

 
Move the renamed backup file to a folder in an existing local file path so that the file 
is visible in the local file manager when you re-open the client. 

 
Example: Move RestoreBib.bib.db to X:\Documents and Settings\[user 
name]\Application Data\OCLC\Connex\Db (where X is the letter of your hard drive). 

5 Restart the client and open the local file manager. In Choose File Type, select the 
type of local file you restored. The newly named file appears in the File list. 

 
To use the file, set it to the default (see procedure above for setting a default local 
file). 

6 To check the records in the restored file, search the file, entering no search criteria. 
 
Example: 

1. Click Cataloging > Search > Local Save File (or click  or press <F3>). 
2. In the Search Local Bibliographic Save File window, click OK or press <Enter>. 

The client displays a list of all records in the file. 

Compacting a local file: 
 

 Removes empty space that remains after you delete records or move records 
to another file. Deleting or moving records does not remove the empty space 
the records once occupied, and the file size continues to grow unless you 
compact it. 

 
Compact a local file: 
— After you delete records from a local file 
— After you move records to another local file 

 
Caution: You cannot compact a local file if it is in use by another staff 
person. 

 Repairs a file when you receive erroneous messages that records in a local file 
are in use by another (unlocks “stuck” records). 

 Repairs indexes. 
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To compact and repair a file: 
 

 Action 

1 In the Local File Manager window (File menu), under Choose File Type, select 
the type of file, and then click the name of the local file you want to compact and/or 
repair. 

2 Click Compact File. 
Result: The client confirms that compact/repair was completed. 

3 If you continue to get sharing violation messages and still cannot open records in 
the file, do the following: 

 
1. Close the client, and shut down and restart your workstation. 
2. In Windows Explorer, check for the presence of a file with the extension *.ldb in 

the same folder as the local file. 
Default location: X:\Documents and Settings\[user name]\Application 
Data\OCLC\Connex\Db (where X = the letter of your hard drive 

3. If present, delete the *.ldb file and retry the Compact File button. 
 

Note: If multiple people use this local file, follow this procedure on all 
workstations that access the file. 
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